Glide all of a sudden thinks Airtable attachment field is an array

Hi there,
Twice in the past two weeks I have a file picker field that gets detatched from it’s column in Airtable. When I search the columns to reconnect it, my attachment field from Airtable doesn’t appear in the dropdown list. Tried deleting the form container and adding a new one - but the “photo” airtable attachment field column still doesn’t appear in the dropdown selection.

Tried refreshing Airtable data, didn’t help. Seems like a random occurrence, and am not sure why it’s happening. Any insights?

So looking at the data sheet table, it looks like all of a sudden Glide is thinking the Airtable attachment field is an array, perhaps? The icon looks like all of a sudden Glide think’s it’s an array field, not an attachment field.

I renamed the attachment field in Airtable to “Photo2” and then glide recognized it as an attachment field… But I have a TON of automations connected via API to the field, and don’t want to have to change the name. When I changed it back to “photo” the field went from an attatchment field in datasheet back to an array field again.

Okay, some further work to fix this. Turns out there are a few records in the database that have multiple file attachments in the column. When even one of those exist with more than one photo, Glide instantly thinks the column is an array. When I delete those records with multiple attachments in the Photo field, on the next update it re-recognizes the field as an attachment field. Is this normal behavior? I didn’t think Glide would have an issue when multiple attachments exist in an attachment field in Airtable…but at least I found the cause of the bug for now…

This is expected behavior.

When an AT field has a singular item (photo, attachment, multiple choice selection, etc.), then Glide will interpret the field as a single value. If the AT field has multiple items, then Glide will convert the column to an array column.


Hey Robert,
Thanks for confirming this is standard behaviour for Glide. I guess for my multiple photo uploads form I’ll need to write that to a separate field in Airtable and have Make split the record into new single records and make sure I keep that field limited to one attachment for all records. Otherwise it breaks the upload attachment field in my Glide interface.

Also am a BIG fan of your videos. Thanks for all your contributions. Couldn’t have built my Glide app without your knowledge and expertise!


Yeah…there’s no “multi-file upload” feature yet.

My pleasure—just paying it forward. When I first started off with Glide in 2019, I had a tremendous amount of help from the community (mainly @Jeff_Hager and @Mark).


Were you able to split the images? How were you planning on approaching this?

I had to create a different column to prevent this from breaking the file upload field on my page. I reached out to Glide and they said thanks for reporting it…so I have a feeling they might be looking into changing this behavior, I hope.

1 Like

Thanks! Weird thing is this isn’t happening consistently. So it through me off. For now I’ll just keep an eye on counters to make sure the remain at 1.

Thanks for your posts here. This solved the same issue for me after trying lots of things.

Well - hasn’t solved it - but at least I know what it is!

The only solution I can think of is to have a separate field for each image which is a shame - hopefully, multiple attachments will be possible soon!