Format of column not sticking when new rows added to sheet

I’ve got several columns in my sheet that contain arrayformulas that insert times into columns based on form submissions in Glide. For some reason, the formatting of those columns is not being respected when new rows are added.

Example screenshot:
image

Is there a way to ensure the formatting in my sheet continues when new rows are added? I need these columns to not be Text, so I don’t want to/can’t use TEXT(HH:MM AM/PM) formulas.

This could also be solved by Glide recognizing date and/or time values in the editor and allowing them to be displayed as formatted dates/times.

Glide does allow formatting of date columns as long as it’s recognized as a date column.

https://docs.glideapps.com/all/reference/data-editor/basic-columns/date-time-formats

However, have you set the date format on the entire column (select the column letter to highlight the while thing)? If the entire column is selected, you should be able to set the format for the entire column and it should stick when adding rows.

Yup that’s my issue — I’ve selected the whole column (as I’ve done in the past), but new rows are not maintaining that formatting for some reason.

I think it’s a bug. I’ve been able to figure out that this only happens when I fill out fields that are conditionally hidden in my form. I’ve got a checkbox that reveals more choice components that list a series of times for the user to choose.

Quick description of form:

  • User selects two time values (From and To), then can select a checkbox to enter two more times that capture their break (the time they are not available).

  • If the user only enters their From and To times and submits the form, the formatting in the sheet is maintained.

  • If the user checks the box and enters times into the break fields then submits the form, the formatting in the sheet reverts to date/timevalues (numbers).

All the choice components are pulling from the same choices column (which is formatted properly) and all columns in my sheet are formatted properly to H:MM AM/PM format.

@Mark have you ever seen this before?

Edit: I’ve worked-around this with a script that will auto-format columns onChange, but it would be better to squash this bug.

1 Like

@shchc Could you share a version of this app that exhibits the bug, please, and tell me how to reproduce it?

Message sent! Thanks @Mark

The same happens with Google Forms. Wondering if it’s a Google Sheets issue.

1 Like

I have this same issue. It only happens in cells whose data isn’t input by the user, but is generated from a formula that references other cells in the row. It seems that the the number the formula returns overrides any formatting.