FORM data writing to Glide but NOT to Google Sheet

Very strange. 43s video here

Have You Tried reloading both glide and google sheets

1 Like

Yup! and rebooted my computer, and deleted the tab that isn’t being written to and recreated it.

@Jeff_Hager Have any ideas

1 Like

Can you please share a link to your app and add to your sheet so I can take a look?



My only idea would be to check the bottom of the sheet, but you’ve obviously done that already.

1 Like

I scrolled down to the bottom of your sheet and saw all of the data.

1 Like


1 Like

you can actually scroll that long

1 Like

Welll, I am really bad at excel and I scrolled down to row 1000 (obviously not far enough). nevertheless, why is it writing way down on the sheet? Did I do something wrong?

The reason is that =ARRAYFORMULA(if(B:B<>"",randbetween(1,10),"")) makes all of the rows that look empty to our eyes, look not-empty to Google Sheet.

Try =ARRAYFORMULA(if(B:B<>"",randbetween(1,10), )) with just empty space instead of "".

More info in our docs:


The way I would write your arrayformula:

=ARRAYFORMULA(if(LEN(B2:B) = 0, ,randbetween(1,10)))

Regardless, we suggest deleting all the empty rows Google puts in your sheet by default.

1 Like

Got it. Thank you so much!

So not filling the value for Len 0 takes care of the need to delete empty rows? Never thought of that.


Thanks for clarifying @david . I had the same issue with blank rows yesterday and I just deleted the rows. But this explains the reason for blank rows.

I’m going to take a basic course in Excel so I can have an easier time learning Glide. Thanks and sorry for the false bug report! :-)))

The technical explanation is, Glide asks Google Sheets “please add this new row to sheet X” and Google Sheets thinks “I see this sheet has 1000 rows! let me add a new row, #1001” — it’s weird. Google Sheets considers empty rows to be perfectly valid rows.


So that means it counts towards the row limitation by glide ?

No I don’t think it’s that way. Glide still doesn’t count the empty rows, but as David said Google sees them as valid rows and just skips them.