Form data not showing in Google Sheet

I’ve set up a form and set it to save to the same sheet. However, it’s not showing there. But, it does show in the Glide Data view. See in attached images the Sheet one doesn’t have the 2 Jan entry which I added using a form.


Is it there is you scroll down to the bottom of the sheet?

By bottom @Jeff_Hager means all the way past all the empty rows, most likely at row 1001 or 1002… if you still started with the default 1000 rows.

1 Like

Thanks, yes, it is right at the bottom of the sheet (row 22545)

If you are using an arrayformula, you’ll need to delete all empty rows. Glide will append new rows as needed. Even though a row appears empty, a formula is still enough for it to be considered filled.

I had this same issue and this post solved it. Mahalo!

1 Like

Please delete all your empty rows. Apart from causing this issue, they also make reloading your spreadsheet slower.

I sure did! Mahalo…

Hi All

Hoping to get some help on this same topic. I followed all the steps above and deleted all empty rows in Google Sheets. Only thing that exists are the column headers. A few notes:

  1. I’ve been testing the form on my phone, and getting no results to show up in either the Google Sheet or within Glide Data.
  2. When testing the form on Glide (on my computer), I get results to show up in Glide Data, but not Google Sheets.

Any advice here. Thanks so much in advance.

Follow up picture of the Glide Data showing it correctly arrives.

Gonna ask some obvious questions. Are you looking at the correct Google sheet? Does your reload button in the builder have a yellow triangle?

  1. I am looking at the correct Google Sheet
  2. No, I do not have the yellow triangle.

A couple things I’m thinking it may be and making a complete guess:

  1. My sheets are protected on the Google Sheet. Would this prevent Glide from ‘back-editing’ the Sheet on the ACTUAL Google Sheet?
  2. Is there a ‘publish’ process to make the form live and working on my phone?
  3. Do I need to edit the Data Type of the destination column so that it can save the data in the right format (i.e Date field, text, num, etc)

I am still getting the same errors at this point. Thanks for the help!

It should just work without doing anything special. Keep in mind that you usually need to close and reopen the app on your phone if you are making any design changes to the app. Data should flow through, no problem.

I’ve protected certain columns in my app without issue, but I don’t think I’ve ever protected an entire sheet. Might be worth trying to unprotect it to see if that makes a difference.

Again, it sounds like you are doing everything correctly, but there’s not much more I can personally diagnose.

Thanks Jeff.

One question: what is this ‘Data’ option used for?

The source section is where you pick the sheet and column that contains your list of choices.

The data section is the column you want to fill with the selected choice on your form sheet.

The data section is the column you want to fill with the selected choice on your form sheet.

on the destination sheet?


Thanks Jeff. That is really helpful.

I am still struggling with the form writing back to the Google Sheet. Have you ever experienced this yourself? I created an entirely separate Source Sheet and Destination Sheet and made both unprotected, yet still not getting updates.

I’ve never had an issue like that. If you place data on the sheet directly, does it sync into glide? Can you share your app and make it copyable?

Yes, if I enter any data on the Sheet it updates Glide and insert as a new record.