Error: "This app has reached its rows limit"

I have an app with a 25,000 row limit. I’m currently using ~12,000 rows.

I was editing an array formula and I think it accidentally added another 18,000 rows to a sheet. I’ve gone in and deleted those 18,000 rows, but Glide still shows the error message and when I look at the Usage tab on the dashboard, it says 29,457/25,000.

Is there a delay before Glide will recognize that those rows have been deleted? Or do I need to do something to force an update.

I’ve already followed the instructions of the AI Chat Bot:
"You are receiving an error message saying “This app has reached its rows limit” even though you are only using 12,000 out of 25,000 rows. This might be due to a timeout issue when the data source is large. To resolve this issue, try the following steps:

  1. Delete any data in the data source that is not used in the app.
  2. Remove empty rows and columns from your data source.

By doing this, you should be able to resolve the error message and continue using your Glide app."

Have you tried manually syncing the data source?


I believe I fixed it. I deleted the component that was referencing the columns with the array formula and the row count seemed to update to the correct amount after that.

I’ll add it back in and see if it works correctly now.

I’ve recreated the component and it’s still working correctly.

Maybe there’s a bug in Glide causing it not to update the row count correctly after the limit is exceeded?

I experienced this before, i think is Glide will update the row counts within 6 hours. Its back to normal right after.

This is also my concern, thank you for this! :slightly_smiling_face:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.