This App Has Reached Its Rows Limit


When testing my app, I get the notification “This app has reached its rows limit”, but I haven’t (500 rows). I have tried to delete some rows in case it was some kind of mistake, but still the same problem. It won’t let me use the app at all!

Please, send help!

Is there any way to solve this issue without having to upgrade to a payable plan?

1 Like

How many rows do you have?

In the app in total? Around 500

Well, 500 is the limit. So if you don’t want to upgrade then the solution is to get rid of some rows.

Be aware that if a table is referenced anywhere in your App, then ALL rows in that table will be counted. Even if you don’t display them all in your App.

I see, I removed until 350 rows but it’s still not working. Maybe it’s because of the references you mention. Anyways, thank you very much :slight_smile:

I have the same problem: 328 listings in Airtable but the Glide app says I have hit my row limit. There are no references to other tables in the Airtable table.

I tried the AI support system, and it repeatedly asked me to check my Glide data table. When I attempt to do so, I am not offered a list of sheets to choose from (as the AI suggested) but just see a single row of data apparently copied from my Airtable table.

How do I convince the Glide app that I have only 328 listings?

Are you sure there are no other references used by Glide?

The concern is if GLIDE is referencing another table not Airtable.

This includes adding, editing, and Deleting records even if those records are not displayed in your app.

One way to double check would be ‘find all uses’ in the Glide Data editor.

You’d have to go through your app column by column (in Glides editor) and see if there’s something connected that you possibly overlooked.

Thanks, but as I said in my post, when I go into my Glide data I see just a table consisting one row, apparently a replica of a row in the Airtable table.

I don’t understand your reference to “adding, editing and deleting records”. Do you mean that records that existed but have been deleted still count?

I have to admit that as a general observation I don’t know why I would have any Glide data at all - my project revolves wholly around an Airtable table. I have not knowingly created any data in Glide.

Sorry if I seem/am ignorant, but my reading of the docs let me to think that I could just work with an Airtable table as my data source.

Lets say you have a table which is simply a log and you are adding rows to this table from a form in Glide. That log table will count against you even if you are not displaying it in your app.

Could I see a screenshot of the Glide Data Editor?

This is true but I’d recommend doing any calculation in Glide itself E.g. A+B

It’s much faster doing calculations in Glide because you can harness the power of the Users device. Doing the logic in Airtable will introduce a delay because Airtable needs to sync with Glides server and then Glides Server to the Users device.

I’ve never used AirTable before so perhaps someone with more experience can help.

I think I may have stumbled on the root of the problem.

My app has 4 pages, each with a map displaying a selection of listings from the source table. Some listings get selected on more than one page (eg inns get selected for the food map and the lodgings map).

If I total the listings that get displayed across the 4 pages, I get 374. Still not enough to take me to 500. So it then occurs to me that this multiple counting thing might also apply to the several versions of each map, produced via the user filter at the top of the map. This specifies a geographical region to be displayed. So every listing gets displayed twice - once on the overview map, and once on its regional (filtered) map. But that would take me way over 500 rows.

So I am no further forward, in fact.

I have now discovered that there are two icons labelled Data on my main Glide editing screen. I have been using the one bottom left. I now realise there is one top centre, and when I go into this I see that it lists all the tables in my Airtable database, only one of which is used in my app. So I have unlinked the unused tables, and my problem is solved.

Thanks for your input!


I’m glad you solved it :mechanical_arm:

Good to know and I learned something too! :beers:


@chrismgill Can you confirm that you do use the other tables in your base somewhere in your app? I would be surprised if they are counted if you do not reference it somewhere.

Hi. I can find no reference to the other tables in the table used in the Glide app. I have unlinked the extra tables; the number of rows now matches the number in my core table; and the app still seems to work. So I conclude that the rows in the unnecessary tables were being counted.

1 Like