Error deleting rows

First time reporting a bug? Refer to our Start Here post.


Team ID:

  • In the Glide dashoard URL, e.g.
    https://go.glideapps.com/o/qAopAro1j6fupQs0ylFX/

App ID:

  • In the Glide builder URL, e.g.
    https://go.glideapps.com/app/Gd8K2WzCBfi30fbJLjQ0/layout

Description

  • There is a bug when a custom action consists of several parts. The action looks as follows: “Show notification” - “delete-relation” - “delete-relation” - “delete - this row” - “go back”. When the action reaches “delete - this row” the action is aborted and the current row is not deleted.
    The unsuccessful attempt is not recorded in the history either.

How to replicate

  • List the steps, in detail, for recreating the issue.

Is there a chance that one of your relations is empty when this fails? I’ve noticed in the past that the action sequence will stop if you are trying to do something via a relation and that relation is empty.

I’ve done something somewhat where I have 2 Set Column actions via relations. Sometimes one or both of my relations are empty and the entire action sequence stops before it finishes. I’ve had to set up multiple conditional branches to account for every possibility in the relations are filled or empty.

I’ve checked several times. The relationships are there. Deletion by relationship happens, but when it comes to deleting the parent row, the action is aborted. And the aborted action is not recorded in the history.
I noticed that if there is only one “delete relationship” action before deleting “this row”, the action works without any problem.
Is there any way to upload a video here?

You can use Loom to record a video and share it here.

I get lost in cyrillic writing, so I had trouble following along, but it did look like both relations had matching rows in the other tables.

Do either of your relations have a lookup column that returns a value used to build the other relation? Can you show how those relations are built?

If you add a short wait action between the delete actions, does that help at all?

I have renamed the required fields to English. Adding a wait action did not change the situation. The action still does not want to work with the layout all the way through. However, when using the “Run” button, the action works completely

I encounter similar problems in my other application as well

Can anyone help me?

Sorry for the delay, and thank you for the second video.

One thing I noticed is that according to your actions history log, your action appears to be using the third IF branch, which only has two delete actions. If I understand correctly, you are expecting the actions to run in you first IF branch.

I would be curious to see the action that is configured for this button?

I could be wrong, but I’m beginning to wonder if the screen with the delete button is attached to the wrong table, so when the third act branch runs, ‘This Item’ is not the table you think it is.

1 Like

Hello.
I recorded another video where I tested each of the three action branches. Everything works fine via the “Run” button and everything is deleted. But through layout action fully works only on the branch with relation with elevators. In the other branches the relations are deleted, but “this item” is not deleted.
The button you have shown is linked to the table with cars on all screens.
And the action should delete the rows linked to the car in other tables, and then the car itself.
I think this is a bug and not some mistake of mine, because everything worked without any problems before.

I’m not immediately seeing anything wrong.

To help me better understand, for example, your button that opens the slide in is on the work order screen, and that button uses the car/relation to open the slide in screen that should be linked to the car. Does that sound correct?

I have a small request. Can you change the action Target for that button from ‘Slide’ In to ‘Current’? I’m wondering if there is a bug and ‘This Item’ is linked to the wrong table. Maybe it’s trying to delete from Work Order twice instead of deleting from Work Order and Car because it thinks Work Order is also This Item.

Just wanted to record you a new video and Glide suggested installing an update and restarting the app. Started checking the actions and everything worked! Checked several times from different screens and everything works!

In a copy of this app everything worked too.
It turns out that my problem is solved.

Thank you Jeff for trying to help me

1 Like

That’s great to hear!