Embedded Vimeo videos give error message

Hi, since a few days some of my users are experiencing problems watching embedded vimeo videos (used the video component). They get a error message as attached.

I got in touch with Vimeo and they told me it could be smth with the iframe? No solution, as the videos still wont play. Is anyone experiencing this problem as well?

Is this an issue with all Vimeo videos or just certain ones? Can you give us a link so we can test?

Hi! Thank you so much for reaching out. Its with all vimeo videos. Example links:

Hope you have an idea on how to solve it :slight_smile:

Are you using a Video component, or Web View?

I just tested one of your videos in an app. It works fine in a Video component, but not in Web View. Probably because Vimeo doesn’t allow iFrame embedding.

Im using the Video component :slight_smile:

The weird thing is, it has been working for almost a year. And suddenly I have this problem…

That’s odd.
I just tested further by publishing my app and testing with a mobile device.
Same result, Video component works fine, but Web View does not.

Do your videos work in the app builder?
What if you try deleting the component and add it again?

Hi Darren, thanks for helping me trying to find a solution! Videos work fine in de app builder AND also on my own phone. That is the strange thing.

Also, my users are experiencing this problem on and off. So the videos don’t work for a few hours, then one works, and then all the videos give an error message again.

Allright, I will give your suggestion a try now.

hmm, that sounds like some sort of intermittent network related issue.

Here is something to try: the next time one of your users reports the video not working, ask them to open the same link in a browser on the same device. If it also doesn’t work from the browser, then that would rule out the possibility that the problem lies with Glide.

1 Like

Hi Darren, allright. You mean then the issue would lie with Vimeo?

Perhaps, yes.
Although I’m not really sure.
The original screen shot that you posted shows an error message that clearly comes from Vimeo.
This indicates that Vimeo is reachable from the client device, so maybe my previous suggestion that it’s a network issue is off base.

Testing in a browser is still a good idea. The result of that test should inform your next steps.

Thank you! I informed a few users, hopefully soms test results soon.

Hi Darren, a few of my users tested your suggestion. Conslusion: the videos couldn’t be played in de app, but could be played in the browser (the same videolink, on the same device).

What could be the next step?

I think at this point (unless anyone else has any ideas), I would probably contact Glide Support.

Maybe you have any more thoughts on how to solve this? :smiley:

Thank you. Unfortunately I am already waiting for three months on another bug to get solved so Glide Support is not an option now haha :slight_smile: But let’s hope someone else knows the answer!

What exact link are you trying to use in the app? Does that contain something like “embed=true” etc? Can you copy paste the link here?

Also, what type of devices do your user use?

Hi! The exact link is for example this: Live Q&A 1 maart 2022

Devices differ from:
iPhone 8
iPhone 13
Samsung Galaxy

Sorry but that loads perfectly normal for me on my iPhone SE. How does it look like on those devices? Do you have screenshots?

See the screenshot in his very first post in the thread.


It’s odd. I ran out of ideas :thinking:

1 Like

Well then I would ask the Vimeo team to look deeper into the issue.