Email Column

I have 2 email columns in my spreadsheet.
Glide will recognize the 1st column as an email but Glide recognizes the 2nd column as text.
Why is this? Am I doing something wrong?

It largely shouldn’t matter. Type is usually determined when you load the sheet and Glide tries to make a best guess what the column type is. It looks like this could affect how the basic table works, but mostly it shouldn’t matter, unless it’s a date column. Is there something it’s not letting you do? Hopefully someday Glide will let us change the type of existing columns. You can however set the column type when creating a new column within Glide.

I am trying to use the 2nd email as user signed-in but it doesn’t give me that option since glide thinks it is text.

I think it’s going to base the column type based on what you have in the first data row. Is the second email in your first row empty? Can you try filling it with a fake email address and then reload the sheet?

That did not work

Hmm, I was hoping that would work. I have a similar situation, but it doesn’t affect my app at all since I only use it for display purposes. In the data view in glide, I put a fake email in the first data row and after a few seconds the icon in the header changed to an @(Email) icon.

Another option would be to delete the column and recreate in the Glide data view as an Email column.

Another option is you could try creating a row in your sheet that’s up top, but with all columns filled, so Glide recognizes all of the column types based on that first row. Then you could filter that row out of view.

Thank you for your help.
I am going to try both to see which one that works best in my app.

Again, thank you for your help.

1 Like