Copy App doesn't copy the my spreadsheet scripts

My google sheet has scripts, but they do not copy when I copy the app from one user to the next

I tried with one of my apps, and the scripts copy over. Triggers may need to be set up again. I don’t know what happens when another user copies the app. Scripts may be a little more deeply tied to a users account. I suppose Glide has no knowledge of your scripts and has no reason to copy them. It also might be a permission or security issue, but I have no idea. Do scripts copy over if you copy this app, or just the sheet?

No scripts copied, just the sheet

I’m guessing google blocks scripts from being copied with a sheet to a different user.

Any suggestions for workarounds? I’m not at all familiar with the publishing options, but would publishing the script as one of the options fix the problem?

Just write up instructions with the script code included and how to get it set up and running.

I just tried to copy a google sheet from one user to another and the script copied. Seems to be a glide problem

I don’t know. It’s either a Google API limitation or a user authority limitation. You initializing a copy of your own sheet it different than somebody else or a third party like glide initializing the copy. They may not have full authority to everything in your Google account, such as scripts.