Column Type for Range Between 2 Numbers

Hi, I’m trying to figure out which column type to choose for a column that has numbers in it. I have 4 different groups: well below benchmark, below benchmark, at benchmark, and above benchmark. Take a look at this screenshot…

I’m trying to configure the column type to where if a number in a column is in between the range, then it will give me a certain emoji. I tried using if_then column type, but then realized that it doesn’t really give me the ability to stop at a certain number. For example, I can choose greater than or equal to a certain number, but I can’t necessarily tell it which number to stop at so that it doesn’t go beyond the range I want it to focus on. Does that make sense?

Could use some help with this one. Thanks so much for your time.

IF-ELSE column has multiple criteria… start from well below and end at the above benchmark…

1 Like

Hey Spencer! Congrats on being a Glide Ambassador, BTW.

@Uzo’s way should work—I’ve use that method in the past, but now I do something different.

Recently, I did something sim similar when determining a user’s rank (between a minimum and maximum amount of XP). It’s not super simple, but it’s super flexible and prevents you from needing to use if-then-else columns.


actually is very simple LOL…

Right, that’s what I was saying—it’s easy if you know those numbers will never change. However, If for some reason you need to edit the thresholds, you’ll need to go back in and edit ALL those ITE columns.

That’s what I love about Glide—more than one way to solve the problem :slight_smile:

1 Like

can you just put it as a variable in the if-else column???

possibly…you’d need to create single value columns for each variable…in the end, probably more columns than the 6 I was proposing, though.

One for each column… and you can create a nice CSS table… your method is great for a big number of benchmarks… but it will not give you the option to create a 2D table…

Bob, thank you SOOOO much! It makes total sense with how you explained it. Off to create some columns. Appreciate your time, sir!

And Uzo, thanks for your suggestion as well. I might see play with that to see if I like that solution better. Thanks for your time!


there is a link under the images to the live sample…

1 Like

Ahhh, thank you. Checking it out now.

I add a clickable CSS inline list table… LOL

CSS table

I always want to do it… :wink:

Who knew… you can actually create a nice table from the inline list…


Ok, I’m getting an error message now in a number of columns, which has rendered Bob’s solution useless now. It was working perfectly this weekend, so I’m thinking it has something to do with Glide, and not the way they’ve been set up. Here’s the screenshot below. When I click on Reload, nothing happens. When I click on Learn More, the page won’t open, but it points to this →

Any idea what might be going on here?

What type of column is BOY_index?

I just had a quick look at Bob’s video, and it looks like it might be the Find Element Index plugin?

That error indicates that the plugin isn’t loading correctly. What happens if you re-create the column?

Well, it’s just a Sort Array column. Is that a plugin? I didn’t think it was. Let me try recreating it. It’s weird though. None of those column types that Bob showed in his video, and the ones I was able to use, are coming up for me. They’re completely gone. Only one still there is Make Array.

Yes, it is a plugin. You can tell that by the column type:

All the plugin columns will appear as “Experimental Code” type.

I don’t think it’s a Glide bug, because if the plugins had suddenly broken then we’d all be affected. More than likely it could be related to your network, or the state of your browser.

If re-creating the column doesn’t help, try reloading the builder. And if that doesn’t work, try removing all Glide related cookies and then login again.

Can you send me a screenshot of what your menu displays when you hover over Other. When I click on Experimental Code, the page is still not loading for me. Is it loading for you? My internet is otherwise working great. I’m getting a 404.

Do you mean this?

I’m not sure what you’re referring to. Click where?

Yes, when hovering over Other, you have a bunch of options under the Experimental heading. I’m not seeing all of those options any more. The only option in there for me is Code, and then Experimental Code, and nothing else. Weird.

Okay, sounds like your builder is in a “broken” state. I’d suggest trying the below: