Can't open camera on Android

Hi everyone!
I published an app and I have a problem, with an iPhone I can take a photo or upload a photo, but with an Android phone I can only upload a photo. How is possible? I checked the permissions but all seems ok.

Thank you so much!

Hi @brigop

Can you record your screen showing us what’s happing please?

Shure! I’ll attach a screenshot.

I used a image picker element. When I press to insert a image automatically the app open the gallery.

Do you have this option selected for your image picker?

If you do, have you tried another android device? My guess is that either the OS or the browser is restricting access to the camera. If so, that’s something you need to figure out on your device. It wouldn’t be something that can be solved on the Glide side.

2 Likes

Hi,
I’ve tried and I discovered that on my Galaxy ZFlip 5 (and on Zflip4 of my customer) the camera works only if in the element image picker you select only the “camera only” option.

Thank you for the help!

2 Likes

Just ran into this as well and I am on a Pixel 8. Camera only allows camera access, but Camera and Roll does not allow camera to work.

Didn’t try Camera Only but can confirm that Camera and Roll on Android 14 does not bring up Camera option. Interesting that Camera Only works though. Maybe there is something Glide can do to correct the other setting.

1 Like

I know there are downsides to this, but we have noticed that if you use the File Picker and not the Image Picker that the camera is available as well as the media / files. Now, this would allow file types other than images of course, but it does make it “work”.

2 Likes