Can't download file by the link from the app

I created my first glide app, a library for my family. Put .epub files to google drive, put url into google sheet. Url opens ok but but pressing download button doesn’t download the file. It does nothing.
The same url sent to the phone by Telegram lets download the file.
Did I miss something?

Do you have screenshots, a video, or a link to the file that you are able to share? I’m just trying to visualize what you are seeing.

Have you tried changing the action to show show the sharing option instead of just opening as a link?

Her are screenshot:
The link itself is the following:

I added your link to one of my apps to try it out. When I click on the link, google drive opens and say Unsupported File Type. Then I click on the menu and select download. I was able to download it, but I don’t have an app installed that can view it, so that’s about as far as I got. I tried this on Android.

It could be the url you are using. If you share the file and get the sharing linK (should look like this:, it might work better. Didn’t make much of a difference for me, but it might for you.

Também fiz o meu primeiro aplicativo no Glide, Eu fiz um de podcast e coloquei nele um componente de áudio para tocar e fazer o download. Ele toca perfeitamente mas nada acontece quando eu clico em download nos três pontinhos. Percebi que ao minimizar a janela do browser pela metade funciona perfeitamente mas maximizada nada acontece. Alguém pode me ajudar com isso?