Cannot Reconnect to Google Sheets


I always use Glide tables for my apps, but had previously tried a few Google Sheets too. I had created a Google account with my work email address (that is also linked to Glide) and it had worked.

I had to sign out of that account and into a new Google account to do something else. Now, I can’t make Glide reconnect to the original Google account, I just get the error seen in the attached screenshot.

I’ve tried signing out of Google and Glide, signing back into Google and then Glide, but the problem persists. Any ideas?

You could try clearing your browser cache.

Hi Jeff, I just tried that and it hasn’t fixed the problem unfortunately. Is there a way to force a sign-in again to Google via Glide?

I’m not sure. Have you tried a different browser or incognito mode? My first guess would be that something is still cached but I’m not sure. Hard to say if you are dealing with two different google accounts.

Unless someone else has a suggestion, my only advice is to contact Glide support.

1 Like

Did you also delete all Glide and Google related cookies?

If that doesn’t help, then yes, submit a support ticket.

1 Like

Still no luck, but thanks for your replies, Darren and Jeff.

1 Like

I am having the exact same issue, just submitted a ticket

Thanks Fernanda, I’d love to know what the issue was if you find out…!