Camera Access Permission Notice on Screen

I have a Private Pro App, I notice when using the linear scan barcode, the cameras ask for permission from Glide. How can this be changed, so user is getting permission from my business?

That is showing the domain of whatever url was used to open the app. If you want it to show something else, then create a custom domain and only share the custom domain with users.

Just want to add that the message is issued by the browser. Not by glide. So there is no way to control what it says. It is there to protect the user. Imagine ending up on a fake phishing website that begins asking for permissions. Would you want it to show the correct url, or have it faked out and say something like Microsoft or Apple. You don’t want to “trick” user’s into giving access to something like their camera. That’s why the message shows the true original of the url that they used to visit the site, so they can verify what is really asking for permission. A custom domain would give you your own branding and the message would reflect that as long as that’s the url that they used to access the app.


Ahhh, right. This makes sense and I agree. Thank you. I have a custom domain. So, maybe I should reload the app and test again on my device? When sharing the app, I did use the customer domain generator to get the needed DNS settings.

1 Like

Yes I would uninstall the existing app and reinstall by visiting the custom domain instead of the glide domain.

Well, this is not the issue. I published my website, and of course, and now the subdomain that worked yesterday, is strict redirect to the site. I get no page informing or allowing users to download the app. The QR code and all else act the same without giving someone the ability to download the app. The only landing page is see with the ending. I will check my DNS settings again. I did notice that when I change how users log in the required DNS information defaulted to in the TEXT and CNAME fields. Here is what else I notice, there is something off with the value, when I use my preferred subdomain as the Host value. The CNAME keeps returning I thought I fixed it. When I remove the subdomain Glide gives me green check marks, but when I scan, I get redirected to the original problem…“unable to connect website”…Geesh…

After hours and hours, I’ve had some and no success. I figured out that in order for Glide to read my custom domain, the site had to be published. There was much success with the DNS settings, however, I’m still getting the at the end. The scan is not configured to show my domains at all. It either accepts ( This is really disappointing after going Pro. After pay so much for Pro features, etc, this continuous Glide branding is a little disappointing. Any help would be appreciated. Thanks.

I’m sure that something just isn’t configured properly. I’ve seen plenty of users with their app set up to use a custom domain, such as or Unfortunately, I’ve never set one up myself, so I’m not much help there. You can search through the forum for other threads that discuss how to set it up. Also, have you checked out any of the glide documentation?

1 Like

:laughing:Well, befuddle me bruisers! I removed all the DNS settings for the Glide app, empty caches on both my broswers after leaving the Glide and my custom websites. Now, when I signed back into Glide and went to the share app section. I see my custom domain for the link, but above it of course, the…When I scan the code, of course it does not work, because there are no DNS settings, but the scan does pull up my custom domain name…lol.This is really a bugger.

1 Like

Finally, issue is resolved for now! My host does not accept the record type “AAAA”, so I was constantly playing with adding and removing “A” records and “CNAME”. My host was not always accepting of it. Then, once I created my subdomain via the custom name area in the sharing location of Glide, and took any new settings and put them on my main site. I had to clear the caches, and close all sites to refresh, and wait at least 20 minutes. Issue resolved for now.

1 Like