**Bug** with Progress Bar?

I was trying to create a progress bar object.

Progress bar rendering is messed up if the google-sheet cells were formatted. For e.g., I had them formatted for currency $.

It got fixed as soon as I removed the number formatting, and made it default ‘automatic’, it started rendering correctly. Is this known behavior?

Details in the thread below.


1 Like

Please Chek the Column Type of that cell in the data editor. What type is it?

1 Like

Column Type is “Number”

I saw more interesting behavior. When the column is formatted as currency in the spreadsheet, the column editor converts the Value to a floating point. Let me explain:

Spreadsheet shows: $1,560

Data Editor shows: 1.56 (depending on the precision)

I’m assuming its using the European convention of converting the ‘comma’ into a decimal point which is what is causing the issue.

More understanding of the problem. Still not a solution though.


1 Like

It’s interesting. I’ll experiment with this later when I’m in front of my PC. In the meantime, what if you change the country settings in the spreadsheet?

1 Like

that didnt make a difference. I changed the time zone back to US pacific time.
But it was never in CET or other european time.

Still giving the same error.

1 Like

I took the test but here it works fine. What are we missing?

1 Like

Hi Roldy,

I followed it precisely as you said now. It works!


I am unable to reproduce the error! :frowning:
I’ll keep in mind the above specifics because this is non-intuitive since there is nothing to suggest that I did anything other than just reinforce the values from the Data view.

I’ll report back if I am able to reproduce the error.


1 Like

Still odd, but I wonder if your funding status column was the problem and maybe was being recognized as 1, but your funding goal was being recognized correctly as 1560. That would explain the progress bar showing 1%. I would lean towards a sheet issue, but I don’t know. I usually avoid any formatting in the sheet if possible, but like you said, if the data is imported from elsewhere, then that’s hard to control.

I guess this is happening because your spreadsheet is setup in european language, but what about your device? What’s the language/location of your pc/laptop? Maybe glide is not recognizing it because it’s different from the spreadsheets

No. The spreadsheet is not setup as EU. The time zone is properly set to US pacific times. If theres something else that was changed I do not know. I had to do the steps suggested by Roldy. Not sure why it would make a difference because nothing in the cells suggested it should. It seems to be working now.

Time zone is not the same as the region/locale of the google sheet.


correct, and that is the current setting as well.

1 Like