Form submission does not show in google sheets

Hey there, I am having an issue with a form submission.

I can see the inputted values in the data view of glide, but strangly I cannot see it in the google sheet itself.

What is even stranger is that apparantly zapier does see the new row since it triggers my requested result.

Can anyone help.

I looked on the forum. But do not see the exact issue.


Scroll down to the end of your Google Sheet

Damn, thanks, sorry David, rookie mistake. The formatting however is not taken as the rest of the rows. Which creates someting strange in the zapier generated document. I tried formatting in Glide but that does not work well the € are not taken and the % is not possible. Any pointers on how to solve that?

This happens when you have empty rows in your Sheet, so I would advise temporarily turning off your Zap and delete all empty rows, then turn it back on.

Can you clarify more on the formatting? If you are triggering based on new rows in Sheets, you should make sure the formatting in the Sheet is correct.

1 Like

Unfortunately that does not work. Just tried it. A new row takes new formatting. and not the one of all the previous rows.

Picture shows all the rows and the last entry:

  1. Montery values become just numbers
  2. Percentages become just numbers (which is really annoying for a reader of the zapier generated document.

Oh, should have said the first paragraph refers to only the reason you were seeing rows at the bottom of the Sheet.

Regarding the formatting, are you using a Sheet format to include those euros symbols?

do you have any arrayformula in that sheet? or you cut rows to the last entry?

Thanks Thinh & Uzo for the help,

I use arrayformula’s and I have formatted the google sheet colums to be:

  1. numbers (if it is a number)
  2. valuta (if it’s a euro amount)
  3. percentage (if it is a percentage)

The strange thing is that when a row is added on form submission it “forgets” the formatting in google sheets.

I would really appreciate any help with the solution.



When you apply the formatting, do you highlight the column by selecting each cell in that column, or do you click on the column header to select the whole column at once?

I’ve had this happen to me a long time ago (and maybe still does), but I also stopped relying on the google sheet for formatting and only rely on it for data storage. Either way, I try to make sure the formatting is applied to the column as a whole instead of picking all cells in the column. Hope they makes sense.

I’ve found that even this doesn’t always work.
Anytime I really need to enforce column formatting, I’ll usually just include a setNumberFormat() call somewhere in a trigger script.


Thanks for the tip, but to no avail. That is what I have done. It still does not keep the number formatting. It makes glide unfortunately complete useless for my desired use case.


In a case like that, I would probably create additional columns with arrayformulas that create the formatting in the formula. It’s not ideal, but you would be guaranteed the the proper format would be applied to each new row, and hopefully your zap doesn’t need too many of those columns.

1 Like

I think I found the solution:

This script seems to work.

Thanks for the help everyone.




I spoke too early, it takes the formatting. Not the number formatting🥶