Bug / Question about Form Buttons Updating Spreadsheets

I can’t seem to get a Form button to update the sheet with information. I have included a video illustrating this potential bug. I’d really appreciate any help you can offer!

Video of Glide App Problem

Oh and I definitely have tried pressing “Reload Sheet” and gotten no success.

Follow up second video to the bug, I may have figured out a work around, but I’m super confused about what is going on…

2nd Video following up on Glide App bug

Can you verify that you have refreshed the data editor and scroll down to the bottom of your sheet to check if the form response is there?

I just tried that and it’s all blank still.

You don’t have any weird security settings on your sheet do you?

I believe everything is default settings. What might be causing it?

I don’t know. Just shooting out ideas. Could try creating a new sheet.

Hey Jeff, that was a great idea! I’m not sure why I didn’t try that sooner. Thank you guys for all the help. To fix it, it seems like I just had to Duplicate the whole app, and the new copy of it is working as expected. Still not sure what caused it in the first place