Boolean Not Working

Hi everyone!

I want to add multiple columns, each of them as a Boolean. However, everytime I create one, glide automatically changes the column to this:

The last 3 rows named “preClean…” I chose them to be booleans but after I made them they changed to that icon and now I can’t delete them either.

I appreciate everyone’s help.

I’m not sure about the boolean issue, but since you’re using Google Sheets, any basic columns need to be deleted from the Google Sheet — only User-specific or Computed Columns can be deleted from the Glide Editor.

Have you tried duplicating the Boolean column (Clean_Item1) to see if that works for you? Your columns are also named the same, which could be causing an issue and Glide may be trying to create an array out of the similarly-named columns.


By any chance in your Google Sheet do you have consecutive columns named preClean_Item1, preClean_Item2, preClean_Item3, etc.

If so, you’ll need to rename your columns in Google Sheet or not make them consecutive to avoid having them be displayed as an array column in Glide’s data editor.


Thanks Kyle and Nathan!

It seems that the problem was that the columns had consecutive names, so Glide turned them into an array.

By not making them consecutive it worked.

Thanks a lot!


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.