Allowing users to sign-up

Hello all,
I’m having some trouble with users’ profiles and allowing new uses to sign up to the app. When I go to view another user my text input fields will not show up.

Can you share more about how this screen is configured?

Which table is it attached to?
Does that table contain any rows?
Are any of the columns in the table marked as Row Owners?
Do you have any filtering applied?

Hey Darren,

The onboarding screen is attached to the user’s sheet.
The table only contains one row and that’s the admin row I used to build the app.
None of the columns are owned.
Filters are “is sign-ed users”

Here’s a screen shot when I view as myself.

You do have row owner applied to the email column. The small blue icon next to the column name is an indicator of that. Plus the fact that the 2nd row is greyed out.

But that’s fine, it just means that you don’t need the filter. You can remove that.

So what happens if you view as the second user in that table?

What should happen is that you see that the first row in the table becomes greyed out, and the input fields should be enabled, allowing the user to save data to that second row.

No row owner applied to the email column.
What should happen is a user should be able to onboard but the app is not taking them through the process. When I add users to test the onboarding the input fields are greyed out.

Are you saying that you removed the row owner setting from the email column?
If you did, then you will need a filter - and your last screen shot shows that there is no filter being applied.

Also, you are viewing the app as “anyone”, and as “anyone” doesn’t have a row in your users table, then what you see is expected. Also, I’m not sure what the purpose of the random sort is?

For something like this, what you want to do is “lock” the user to the correct row. There are two ways to do that. Either by using Row Owners, or by filtering by signed in user. It seems like at the moment you’re doing neither?

The “blue icons” indicate user-specific, and I’m unable to see my other user.
When I sign up as a new user the app is not taking me to the onboarding screen.

No, not for your email column. That little blue man means that column is configured as a row owner.

Yes, I can see that some other columns in that table are User Specific. Which raises another question - why? User Specific columns are rarely necessary in your User Profiles table, because you generally only give each user access to their own row.

And this brings me to another question - have you actually configured User Profiles? I suspect that you haven’t, because you wouldn’t be able to with only User Specific columns in that table. I’d suggest that you do that before you go any further. You’ll need to replace those user specific columns with basic columns - at least one each for email, name & avatar/image.

You’re right I need to configure my User Profile. I’ll do that. Thanks Darren.