After Duplicating App (now shows "No User Data") and is not writing to the Google Sheet

The app was working fine. New users would sign up and their data would populate both the Glide spreadsheet and my GoogleSheet.

Then I decided to duplicate the app (just so I would have a backup – thought that was a good idea).

But when I did that, the app is now listed as having “No User Data” – see attached image, instead of “A Few Users”, which is what it said before. And when new users sign up they are listed on the Glide spreadsheet, but not my GoogleSheet.

I have tried to reload both the Glide Sheet and Google Sheet - no resolution.

Could you help me with this. I have made no other changes to the app itself.

When you duplicate the app, it is an entirely new app that has no bond with the original app, except that it copies the full settings, data and layout etc. at the point you duplicated it.

The “user data” shows the amount of users/devices that accessed the app in the last 30 days. It’s logical that your copy has no users. This paragraph is to make sure you don’t misunderstand the “user data” here with the user profiles in your Sheet. They are not the same thing.

Thanks ThinDinh,

We had 10 new users sign up the last 24 hours. The same message occurs “No User data” occurs.

More concerning to me is that the new users are not being written to the Google Sheet. Any thoughts.


Do they sign up on your original app or your copy? It is the amount of the devices that accessed the real app, not the count of users on the profiles sheet.

Probably those rows are being written at the bottom of the Sheet, if you have not cleared empty rows.

They sign up on the original app, but none of then show up on my Google Sheet.

Here is an image of my Google Sheet (with no new names) and my Glide Sheet (where the names appear).

I have not touched the Google Sheet (not sure why the app stopped writing user data here.)

Have you tried scrolling way down to row 500 or 1000?

Yes. There they are - 1000 rows below.

It turns out the ARRAYFORMULA in the Google Sheet moves them there. I changed it to another formula.

And then was advised to delete all the blanks rows. Now Glide can’t load the Sheet. Sorry but if you have any idea around this, that would be so helpful.

Thanks -

You can keep the arrayformula, just delete the blank rows and I think you will be fine.

Hi ThinhDinh,

I am stuck. Glide will now not load the sheet.

The app works existing users. But for new users they can sign, but not onboard their information.

Is there anything I can. Or do I have to replace the site with a working duplicate?

Thanks - Carl

Can you try a duplicate to see it it works?

Thanks ThinhDinh,

I tried to replace the Sheet and reconnect under Settings>Data Sync. No success.

I have duplicated the app and the worksheet, and pointed the custom domain to the duplicate. Seems to be working but will monitor as new users join (all my five test new users - seem to be working).

Really appreciate your help

1 Like

“No user data” is a bad label — this just means we’re having trouble counting your recent users. Your app is still full of user data.


Thanks David.

When do you think this will be fixed?

1 Like