Adding step in Action Breaks The Action

I have built a once off chat using Glide AI generate text and am using trebuchet method and JSON to display the current “chat session”.

I have a multi step action that works as expected - returning responses and updating the multi-file column in the user table with the JSON for the entire set of questions and responses.

To improve UI, I wanted to display a spinner whilst the action was playing out. Adding a simple set column (Boolean) in the user table to the beginning of the action broke the action - the multi file chat column is being updated with a blank “response”.

Removing the step to update the show/hide spinner (boolean column) resolves the issue.

Can anyone see why this might be the case? The additional steps update a column that is not used in the rest of the action - it is only used in a visibility condition on the screen to show and hide a spinner?

What does the run history say? Can you screenshot the error?

Thanks @Robert_Petitto - No error showing up in the action history even for the failed scenarios. The action actually “worked” except that the user table multi file column was not being updated with the addArray value (from your video :slight_smile: ).

Murphy’s law - I enabled the actions (for visibility condition) again now and it worked as expected.
Bit frustrating - have been working on this over last couple of days and could not identify reason for the issue, only now to be “resolved” without having changed anything.!
Thank you for responding - will continue to monitor.

1 Like