Adding & Editing Not Appearing

alguem pode me dizer se a equipe glide ta trabalhando para resolver esse bug

Could you please all share the apps this is happening with?

Could you please share your app?

Yes - anyone else experiencing this please share some or all of the following:

I did a copy. I tried to remove all personal data.

The copy won’t have the issue … When you duplicate the GUI of the app it restore the Add and Edit function and Special Values… Its the original thats losing it for some reason

For me it´s not true. I shared a copied app with the same issue.

I see it in that app, thank you. Please don’t modify it for the time being.

Can you by any chance reproduce this issue starting from a new app? If so, could you record a video and share the spreadsheet you used for it?

Weird when I duplicate the app it allows those functions again but then when I refresh the Sheet because ive added another tab or whatever those functions vanish

Can you reproduce that reliably? If so, could you please give us a link to the original app, and steps to reproduce? I assume it would just be:

  1. duplicate app
  2. add a sheet
  3. reload in the builder


@Mark I experienced the same issue when I was editing my app, I reloaded some data and noticed that the Add ‘+’ had disappeared. Duplicating the app using the same sheet does not fix it.

Although when creating a new app the Add ‘+’ appears again. Having spent a considerable amount of time on my original app, ideally I hope to fix the issue rather than create a new app.

I created righ now a new app from this sheet:

After create, I put Add option to Paciente tab. All OK. After I create in sheet a new sheet tab. I reloaded the app and it broken Add option in app.

Its the specific sheet tab. When the add breaks, add and edit components are gone.

I created a new tab and bam add and edit back.

So whatever the reload does to the tab with add / edit components locks it from being added to or edited

As per @Christopher_Breen post above, I can confirm that if I add a brand new tab to my app, the Add ‘+’ feature works for the new tab, but not for the original tabs.

Thought this may help also.

This issue should be fixed now.

If you still have missing add/edit screens, please duplicate one of your sheets in Google Sheets, then reload sheets in Glide.

1 Like

Can confirm that issue is fixed - thanks for the prompt response from the Glide team!

In my apps your tip worked. I created a sheet and reload, but I lost my config in add and edit. I need to do everithing again.

Yes, unfortunately we lost the add/edit screens. I’m sorry.

I´m thinking that I have a very complex scenario with one worsheet and a lot of apps connected. I dind´t change this worksheet yesterday, but if had, I´d have a lot of work to do and users to advise, process stopped, etc. Thanks God for this, but for me it´s a warning to don´t enlarge the scope of apps, envolving more people and more complex scenarios till GlideApps be more stable.

1 Like

I apologize. We’ll be working on this a lot.