Add user does not work. Existing user in table not available

My App/Pages Support link:

Describe the bug:
My user table contains these two users:


The pulldown does not include the first user in the table:


In addition, if I select “add user”, the pop-up disappears and nothing happens.

Expected Behaviour:
It should work, and all users in the table should be available in the pulldown

How to replicate:
Try it and see

See screen shots and support link

What happens if you type the user that you want into the search bar?

Thanks for suggesting that. Same thing happens. It disappears without adding the user to the table.

I don’t know if there is anything useful for you in the documentation. I’ve never done more than preview as one or two users other than myself. Usually I can get away with typing in an email in the search, press enter, and then I think it shows the email or the user in the results. I guess I’ve never used the ‘Add User’ option, so I don’t know what it’s supposed to do. My users are pretty static, so they are already in my user profile table.

For me, If it’s a private app, I usually already have the user table prefilled with the users that can have access. If it’s a public app, I don’t usually attempt to create new users myself. I let the rows generate when the user signs in for the first time. I feel like I have better luck letting the user profile row self generate rather than manually adding it. Manually adding a row seems to conflict more with Glide’s internal tracking of new users. Then again, it’s been a while since I’ve even attempted something like that.

Well, I shared to my phone, and signed in using google with all three of my google accounts, and while it “worked” to sign in, not one of the accounts was added to the user table. It’s been a while since I have worked with a free app (this is on a new free team).

If I type a name in the search bar to “view as” and then select that typed in user, it says “viewing as” that user, but that user does not get added to the users table.


Well, apparently you need to set the table on the “users profile” tab for the names to be added to it as they log in. Thanks for the link to the documentation. I’m thinking that happened automatically in other apps I’ve worked on, because I never had to do that before.



The “add user” button still does nothing at all.

1 Like

That would have been my next question. I’m just in the habit of configuring myself anyway. At least, most of my apps were created long before we had any of that stuff done automatically.

Yeah, I’d have to sit down and play with the Add User button to see it myself. If I ever were to add a user manually, I more than likely would just add it to the table instead. The only time I mess with ‘View As’ is to preview the app as an existing user.

Regardless, it may be worth submitting to glide support if that button isn’t doing anything.

I thought adding it to the “bugs” category on here alerts support.

They might see it but their official ticket system is better for tracking and organization. This is primarily a community forum for users. The glide team is active, but not necessarily seeking out bug reports.

1 Like

Just sharing my Experience :slightly_smiling_face: -: This happens to me sometimes when I’m viewing the app for the first time in the builder!

I mean once I click on one of my app and I’m going inside the builder. After going inside for me also displays like this whether the Users Table has Users and the User table has connected to the User Profile tab!

Once I click on Anybody in the view as menu then I see the all Users.


Closing due to inactivity. This topic will be deleted in a few weeks if there are no more comments.