Zapier : error resulting when builder is not the one triggering the zap

My app’s URL: (public) and https://toujoursdebout06edit. (admin app, restricted access)

HI guys,

Does anyone already noticed the same problem with Zapier : zap successful when I, the builder, click on the zap buttons. But always errors when other app users click on the same buttons?

Is the zapier integration for Glideapps associated to the builder email address?

Very strange, and problematic…

I bought the Zapier pro membership to check if it would resolve the issue, but it does not…

Many thanks for your feedback!


Additional info : my apps, public and public admin are in my Glide organization. That could be the issue : any user not part of my org can not trigger zap?

I haven’t tried. Can you send me the link to your zap?

Not really, the zap publishes lives post on a Facebook page and on Twitter. :blush:

Let me 3 minutes to build a sample app in my org with a zap!

Hum… I can’t @Robert_Petitto. As in my org, I can’t build a public app for free, I have to subscribe a pro subscription to publish it…

Just tried it out with my app. It worked from the builder, from my phone and from a user’s phone (they don’t have a zap account) without any issues. I don’t use Orgs, so I can’t help you there. Have you made any recent changes to your zap that may require some reconfiguring or for the user to force close and reopen the app to get the latest version?

Hi @Jeff_Hager,

Yup, there’s no problem at all when an app is out of an organization. But when a public app is in a org, it does not work for end users, or let say any user who’s not the maker.

I think public apps in Orgs inherit some kind of user controls, which prevent Zapier to work correctly. As far as these apps are public, they must work for any end-user, including zaps…

Znd to answer, no, no changes. The version is the latest, zaps work for me, not for others…

That’s odd. I wouldn’t think that would matter. Sounds like a bug, but like I said, I don’t have any experience with orgs.

I had no experience with orgs too, but as I launched my apps at the beginning of this week, I have decided to start a clean Glide env and set an org. I didn’t notice this zap issue, as for me when building and using the app live, it worked.
But yes, it’s definitively a bug.

1 Like

Hi @Mark , do you know if, for a pro public app in an organization, the Glide’s zap only work for members of the organization? It really seem to be the case. For me the zap action always work, for my two other moderators, not part of the organization (they don’t need to be in), the zap never work, they always get the error pop-up. Quite strange…


@Christophe_HK. I’m looking into the issue right now. What is your auth method on your public app in your org? Is it “Email whitelist” and are your non-org users added to that?

Hi @Seth_Rosetter : yes, pro app with email whitelist. All admin users have access to the zapier button / action, they’re in the Users tab, and I am the only one member of the org.

@Christophe_HK We believe we have resolved the issue and will be deploying the fix tomorrow.


1 Like