Visitor access request does not show up on login screen

Hello everyone,

I am trying to create a private app where a user can request access on the login screen. I think I have enabled all of the correct settings, but when trying to test logging in as a random user, I do not get any access request buttons in the login screen. Does this automatically show when these settings are enabled or am I missing something?

Thanks so much in advance!



Worked when I tried it with those same settings. Did you refresh the app after turning on the Access Request switch?

1 Like

Hi @Jeff_Hager thanks for your reply!

I did refresh and I am still not getting any different results. I created a new app and tried it with the same settings as well and it still isn’t working.

Can you take a screenshot of what I am supposed to be seeing on the login screen?

I am on the Legacy Pro Plan if that makes any difference.

I tried it on an app in a legacy Starter plan:

After entering an email and pressing Continue, you should see something like this:

Thanks for confirming @Jeff_Hager

I still do not see the request access button:

I’m not really sure. Do you have manual publishing enabled by any chance?

I do not have manual publishing enabled. :confused:

Sorry. I don’t know what else to check. You may have to open a support ticket.

1 Like

Thanks for your feedback Jeff! I’ve created a ticket.

1 Like

Has anyone experienced this or know what I could he missing? Support is taking some time to respond. Thanks in advance!

Is this a free or maker plan? cannot sign into those apps because that’s not a personal email.

As mentioned above, I am on the Legacy Pro Plan.

I’ve tried several personal emails with the same result.

Same issue with my app. Same settings. No option appears on login screen for users to request access.

I’ve had 4 different users in the past 2 days with the exact same issue, never had a problem with it before that. Eventually, I had to manually add every one of them 1 by 1 in order to get them in… I’m on the Legacy Pro plan.

Since I had access to your app Trung, I tried and I don’t see any issue!

Not sure but I’m guessing that you are trying in the editor? Like this?