Video : thumbnail

I just tried a YouTube video and it does not work anymore @Manu.n. Is this related to the Replit problem yesterday?

in my test application it still works !!!

test with this address:

If that doesn’t work, send me your video link, I’ll watch !!

Here are my settings (no width and height).

Thanks a lot brother!

Well it works.

be careful, for youtube you should not put a time, but one of the options:
0, 1, 2, 3, low0, low1, low2, low3, medium0, medium1, medium2, medium3, high0, high1, high2, high3, max0, max1, max2, max3

test with this link for video

Yes it is the ‘watch? v=’ which blocks

give me 5 minutes, I will add a few lines of code to avoid this error and be able to keep the links with ‘watch? v =’

1 Like

Thanks bro! Works instantly.

1 Like

Well, I made a little update (a bit messy with yt) but normally your address = ..... works.
Following the next episode.


Thank you that will help a lot!

1 Like

Really impressed @Manu.n!


Still not working completely for me for some reason:

obviously the video is not available ???


I made one too:


but, whether it is your code or mine, if the video does not exist, it does not work :rofl: :rofl: :rofl: :rofl: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes:


Youtube offers 4 different thumbnails (don’t ask me for an explanation) and different resolutions that I have integrated as options.

Because I am a little questioning on the principle of returning data images-uri when the memory consumption and the speed of refreshing of the application.


@david—will it also return a thumbnail for videos uploaded to Glide??? That’s what we really need :slight_smile:

It is available.

That first l is actually a capital I:

1 Like

ah yes sorry, there is a small problem, I am looking at this!

1 Like


works again, a little refresh, and it’s off again …