User-specific notes

Hi, my app lists hotels and for each hotel entry, after the details such as price, address, etc I want the user to be able to use the notes component to add their own comments, booking number etc…
I watched @Robert_Petitto’ s video and also the help page on this but once I add a user-specific column and added a “notes” component sourcing data from the user-specific column, I do not see how the notes field can appear blank under each entry so that people can start entering their info?
So far, either I enter some text in the app admin page on the web and then I can see those notes but they don’t seem to then be user specific. I previewed as two different users and the same text appeared.?

Is the column you’re using for the notes component empty?


Is this the case when viewing the app through different accounts via the published url instead of the builder? I remember trying to test user specific columns in staging, but never fully understood it. It may just be the way that the builder works where you aren’t fully signed in and possibly still primary signed in with your glide account, even though you are using the preview as feature.

Both on the builder and on the app on the phone. I signed in and out with two different user profiles and get the same filled notes field for both

Can you show a screenshot of the note component settings and the column settings in the data editor?

Hi @Stephanie_Bonnet. I think I may have done this with a sample church app, but not sure if this is what you’re trying to accomplish?

Screenshots below. For every sermon, the user can write their own notes. This is what you want to do for hotels? Or no?

Hi everyone, I found the issue! I had not selected the right column in one of the settings for the notes. It’s all working well now. Thank you very much to the three of you for having shown an interest.


No problem. Glad you found the fix!

Hey!! Im having the same issue, and didnt figure it out how to solve it yet, could you tell me how did you solve it?

Sorry, I don’t use Glide anymore so I can’t remember. Maybe my response above “I had not selected the right column in one of the settings for the notes.” can give you a clue

If you want user-specific anything, just make sure the data is writing to a column that you mark as “user specific”

1 Like