Subsequent set columns are not working

I built two actions in two different applications. The actions were similar but were using different conditionals.

For some reason the Data in a subsequent set columns are not being identified.

The action executes only the first set columns.

2 Likes

The conditionals were erased and now it shows a simple custom action that I have not built.

1 Like

I’ve just realized that the action were not modified and the problem is that the actions is not sending the data before the first Set Columns. For some reason the information is not identified in the second Set Columns.

1 Like

The actions only work if I click the number of different Set Columns I have. In this case twice. Because I have two set columns that refer to different worksheets.

1 Like

Thanks!!! I thought I was going mental, but no!! The second set column fails!!

2 Likes

@Jason @Mark same problem here!

1 Like

This is getting stuck many of my apps

1 Like

I’ve noticed weird things too with Set Columns. I’ve seen it set some, but not all columns correctly. I have a ticket with Support to check on some of the weird things I noticed with my calculator app. I have to wonder if it’s related to some of the other issues that people have ran into.

I hit an edge case about a week ago that threw me for a spin. I don’t think it’s related to the issue reported here, but it might be…

A bunch of my users started complaining that a specific button in my app wasn’t working. They would tap on it, and nothing happened. It was affecting many users, but not all. Took me a while, but I eventually pinpointed the source of the problem.

The culprit was the conditional in the above action sequence.
if Free Credits is greater or equal to 3
The Free Credits column is a Number column.
What I eventually figured out was that for many (but not all) of my users, this column was empty.
And when that condition tried to compare an empty column to the value 3, it failed silently :scream:

So I guess it’s a type mis-match error. Possibly debatable whether or not that would be considered a bug, but it’s certainly a trap, and was a horror to debug.

3 Likes

Another similar thing I had noticed is that if the column value that you are using to set another column is null/empty, it will not overwrite the destination column in a Set Column action. I’m guessing it’s tied into how it works now where you can specify which columns are set in a Set Column action. I’m thinking it’s built to ignore null/empty values, which makes sense if you did not set a replacement source in the Set Column action. But if I deliberately assign a source column, I would expect it to overwrite regardless if the source is null/empty or an actual value.

Not quite the same, but there is definitely some unusual results when null/empty is a factor.

3 Likes

I’d post some tutorial videos if it wasnt this bug happens :clown_face:

I doubled the set column actions and it seems to solve the issue…

1 Like

What you mean by “doubled”?

Because, for instance, in a simple trebuchet action I add 3 set columns in one compound action only

That’s exactly what I was doing, until it stopped working all of a sudden. some oofmy values weren’t displaying, so in my chat I had image, message and date, but the date wasn’t showing. So what I did was to set columns for the temporary date (USC) and two to clear that same vale. In fact, I think Robert was having a similar issue and he told me he solved it by doubling the set columns. Why it doesn’t work with one set column…I don’t know. But same way why It works with two set columns… no idea :rofl::rofl:

1 Like

I have this kind of action and it’s not working…

It’s only play the sound and showing the notification :clown_face:

image

I guess the first set column is set something to a temporary column and the 3rd is to clear that same value, correct? Just repeat each action, so have two set columns to add the temporary value and two to clear that value. See if that works

2 Likes

Sorry what exactly do you mean when you say you doubled the set column actions?

I tried to add another Set Column step that sets the exact same fields as the first step but it did not help fix the problem.

Additional info:
I am trying to set a column in a related table (Zone) via a relation on the Attendee table.
It is a 1 to 1 relation (i.e. Match Multiple is not ticked)
Even using a direct “Set Column” action on the “On Submit” does not work :frowning:
BUT doing the exact same Set Column on another screen works.
The screen that does not work is editing an existing “Attendee” record.
The screen that works is submitting a new “Attendee” record.