Sign In problem- Could not connect to Google

For reference:

I’m been having the same problem the past day or so. I was able to fix it by signing in with another browser. In my case, Chrome wasn’t working and I was able to sign in and reconnect google with Safari.

However, if I go back to Chrome it still says could not connect to Google.

:man_shrugging:

Thanks. On a Chromebook you’re pretty much stuffed if Chrome doesn’t work though.

Hi,

I got the same notification of “Could not connect to google”.
How can I solve this and sign up?

What browser are you using and have you tried signing in using another browser?

A Chromebook only has the Chrome browser. Glide just doesn’t work, full stop on a Chromebook. Somewhat ironic as Chromebooks are a Google product.

1 Like

@Pablo_books - aren’t you a Chromebook user?

I’ve pretty much given up on Glide because of this reason. Just tried to log into it once again on my Chromebook and I still get the same issue.

I assume that you have no issues signing into Google services? (GMail, GSuite, etc)
I don’t use Chromebook myself, but I’m pretty sure there are other Glide users that do.

No issues at all with anything else, just Glide. It did work once but stopped over a year ago as per the start of this thread.

I’m currently able to log in to my Chromebook without any issues.
So I don’t think it’s a Chromebook-specific issue.
Japan / 2021.2.11 / 18: 45

1 Like

I am. Logging in almost always works. There are occasional times when I get this error, but reloading the page seems to make it work.

I’m currently on Chrome OS Beta (88)

2 Likes

Check your ADBlock. It blocked the Google login window until it was disabled for this page.

Makes no difference.

Chrome 88.0.4324.190 64 bits
Same here. “Could not connect to google” at Sign up.

Same problem i don,t have a chromebook but i use the chrome browser

Hey ! Welcome on board the community !

It looks like that this issue is related to a previous bug that has been reported a year ago. Can you confirm that this is a new bug or you’ve always had to deal with it ?

A post was split to a new topic: Sign-in issue with chromebook

Initial issue is resolved, please continue here to avoid any confusion :slight_smile:

Thanks !