Sign In Issues


I am trying to sign in into glide apps with my google account and it never gets past the point of “signing in”. It happened a few weeks ago and is happening now. I have multiple google accounts signed into my gmail at the same time but I am sure to pick the right one when signing in for glide.

Can someone please help?

I have multiple Google accounts as well. Try signing out of all of them in your browser and then sign into only the one you are trying to get into. I have had a similar thing happen a few times and that seemed to resolve it. I currently do have more than one signed it so it’s not something you have to do every time.

Hi. It seems that I have the same issue. I did sign out of all my accounts and sign in only with the one related to my glide app. But still not working (see print screens). I can’t create a new app from a spreadsheet.
Should I just wait or there’s a way to solve this?

Screenshot 2020-06-29 at 11.50.56

Ok I solved it just by opening Glide in another browser