'Set Column Values' in 'Add Form' not writing to Excel


I’m stumped by something. Maybe I’ve screwed something up, but I don’t think I have.

I’m using Excel as the data source.

Collecting data on existing people (using “Edit Form”) and new people (using “Add Form”). The “Edit Form” and the “Add Form” are mostly set up the same, other than the obvious difference.

In both the “Edit Form” and the “Add Form”, the user collects several pieces of data that writes to specific data columns, and then I’ve set it that up so that “On Submit” there is a “Set Column Values” with additional data (mostly the user’s name and the current date) being written to other data columns.

Describe the bug:

In the “Edit Form”, where it is writing to existing data rows, this works just fine, and everything is processed within seconds.

In the “Add Form”, something isn’t working properly.

The user collected data and the “Set Column Values” data both immediately write to the Glide table. No problem there.

And then a few seconds later, the user collected data will sync with the Excel file. Good there.

But the “Set Column Values” data doesn’t show up in the Excel file within seconds, like it should (and like it does with the “Edit Form”).

It will eventually sync to the Excel file, but after a bunch of experiments with test data, I still can’t figure out when or what triggers that to happen.

For example, the user may add NewPerson1, and NewPerson2, and NewPerson3. When they add NewPerson1, the “Set Column Values” data doesn’t show up. Then maybe when they add NewPerson2, the “Set Column Values” data doesn’t show up. Then maybe when they add NewPerson3, the “Set Column Values” data for NewPerson1 and NewPerson2 will show up, but not for NewPerson3.

I can’t figure out the pattern. My best guess (and I’m not confident in this), is that there are two scenarios for it to finally sync.

First scenario requires two things. 1. About two or three minutes to go by, and also 2. Another submission, such as an “Edit Form” or “Add Form” to be submitted.

Second scenario requires ten to twenty minutes to go by, and then the data will update on its own.

Pressing the ‘sync’ data buttons, either in Glide or in the Excel file, does not help.

Is this a bug that needs to be fixed with the Excel syncing, or am I doing something wrong? Thanks.

You know, you can add special value components to the Add Form instead of using the Set Column action On Submit. I always avoid using On Submit if I’m trying to modify a newly added row. I feel you run into a timing issues where the row may not fully exist yet at the moment the On Submit runs. Using the built in components is much better since it will add the data when the row is added instead of after it’s added.


You can read more on how to add a special value to a form in the link above.


Thank you both (Jeff_Hager and ThinhDinh) for your responses. Appreciated.

I actually didn’t know about the Special Values components. But I read up on it (coincidentally happened to be reading that exact page when you sent it ThinhDinh), and it was helpful.

It doesn’t really solve my entire problem, as I only happened to mention the user name and date as examples, but there are other additional columns that I was editing ‘On Submit’ that aren’t Special Values.

But then I realized I could just add those components, filter them so they aren’t visible to the user, and set up default value that so that they are added when the form is submitted. (I regret not thinking of this before.)

It isn’t nearly as elegant a solution as using “Set Column Values” “On Submit”. But I’m taking your advice to avoid using On Submit for a newly added row to avoid the timing issue.

Now I feel bad for putting this in the “Bugs” category. Turns out what I needed was another solution, not a fix to the bug.

Thanks again for the help. Much appreciated.


Feel free to recategorise it, just click the pencil icon next to the topic title :slight_smile:
Or if you don’t see that, you should be able to edit your original post and recategorise.


Ha! I just learned another thing. Thanks. Done.

(Although I should point out that I suspect there is some programming that can be done to improve the original issue. But the workaround solution is good enough for me.)


I have the same problem, and I think it’s a bug. I’m using an airtable base and the users can’t edit forms, when is text or add new rows. It’s happening since last updated. Do you know how to fix it?

So what type of value are you trying to set using a set column action?

I found the problem, It was my mistake, Rookie problem. :smile: It was a function not well displayed.

1 Like

In one specific Glide Pages project I cannot add or delete data using any of the various methods available.

This only happens when using Excel as a data source.

Perhaps the integration with Excel is not reliable, or there are timing issues. Point is: Glide Tables and Sheets always work pretty much flawlessly. Excel doesn’t.

If this is the case it would great to understand under what conditions Excel does/doesn’t work so we can work around these conditions.

HI @blairrorani

Could you submit a ticket with a screen recording of this issue?


No :slight_smile:

I discovered a “fix”.
:point_right: Don’t have a tab in Excel called ‘Users”.
Literally the only thing I changed.
Who knows why that worked.

1 Like

I wondered if it was a timing issue but my understanding is that Glide’s data source stores the data and then syncs it back to Excel (when adding from Glide) so that wouldn’t make sense.

I’m having a slightly similar-ish issue. I created a form with button-bar options for users to select an option and each button has a ‘set column value’ to write to the sheet to record their choice. I have special values in place as well, however it doesn’t write to the sheet. It’s weird because it works perfectly when it’s not in a form. Does anyone know why this happens or how to fix it? Thanks!

Can you go into more detail and maybe share some screenshots of your problem? Curious why you are using a form. A form doesn’t create a row until it’s submitted so I’m thinking your button bar actions are trying to update a row that doesn’t exist.


Thanks @Jeff_Hager Jeff_Hager. I’m updating the “welcome sequence” in my existing app so users can share additional info. The simplest way to do it (or so I thought), without disrupting other parts of the app, was to add a form and not a new tab. The form is meant to add user details to an existing row, not create a new row. Is there a better way to do this? I can follow up with a screenshot

A Form screen is meant to add rows. Not update existing rows of data.

I would recommend either a ‘Show Edit Screen’ action, a ‘Show Detail Screen’ action, or a ‘Show New Screen’ action depending on your app flow, which screen your form button is on, and which table you intend to update those values.


The ‘Show Detail Screen’ action worked. Thank you!

1 Like