Serious bug with map and user location

Hi team - since Glide updated, the map and user location function has become unreliable and super glitchy.

  1. User location drops out upon being selected and prompted;
  2. Geolocation, relative to user allowing their location to be tracked, instead of zooming in to user, zooms out to a undefined location.

Welcome any suggestions on how to fix this please :pray::pray:


  1. What do you mean when you say location drops out?
  2. Is that on the map when you activate location?

Do you have screenshots or video of both issues happening?

Hi Jeff - Thanks for the message.
I have attached a video of issue upon opening app.

  1. The app is .map based
  2. As per the video, the user location button is activated;
  3. User location is found on first click;
  4. Prior to update of Glide, a second click of the user location butting would zoom you into say a 500m radius of your location. As per video, this second click function now zooms you’re out to an unprescribed location.
  5. Upon pinching the map to zoom in, as per the video, the users location disappears.

Not sure what’s going on. Have tried loading the app under safari, chrome, Mozilla and even tried a new app. Same issue appears :frowning:

Hope this helps…

(Attachment RPReplay_Final1615071174.mp4 is missing)

There’s no attachement.

Hi Jeff - I cant attach file.

I have attached the URL for app. Maybe you can jump in and have a look for me to see if you experience similar issues with location functionality?

Many thanks
A - :pray::pray:

My experience is a little different…possibly because I’m nowhere near those locations.

  1. I believe when I click on the location button the first time, it is finding my location on the map, but doesn’t reposition the map to my location. It stays within the extent of where the pins are. (My location is in the U.S.)
  2. A second click redirects the map to my current location with a map extent radius of probably 250 miles. This may be what your second click is doing. It’s re-centering to your current location at a predetermined radius. However, it is not placing the map in an un-prescribed location like yours is.
  3. Any clicks after that will not have any affect on the map location. Wherever I am on the map, it does not re-center to my location and the location dot disappears. Zooming does not affect the location dot, but clicking on the location button does.

It seems like we have similar but different experiences. I’m getting the exact same experienced, mentioned above, with Chrome on both Android and Windows.

Jeff - thanks for taking the time to have a look at for me.

Yes, I agree that these are very similar experiences.
Any thoughts moving forward?!? Obviously in glide, there is some limitations with functions of location buttons and maps - making it tricky to get in back end and have a poke around.

In my simple brain, these anomalies have only come about since glide update. Do you know of anyone with the community having similar issues? I’ve even made a new test app to see it similar issues present and can confirm this is the case.

I haven’t used maps very often and I don’t recall any other mentions of similar issues, so it’s hard to say if this is tied to the new builder updates or not. Also hard to say if this is a mapbox issue or a glide issue. The buttons appear to be a part of glide, but the map and I’m assuming the map interface is all mapbox.