Row ID Used in Relation not working

I have a very simple app where i need to total and summarise responses to a short survey from All users.
I am using Glide tables exclusively.
I have an appHome table (where the summary totals will be calculated) with a Row Id column. This AppID is then made available in the users table via an If-Then-Else column. Finally the form that submits a new response record, uses the iteAppID in the users table to update the “AppID” text column in the responses table as the form is submitted.

The text field is working in the responses table - it is set correctly for each record created. Why would a relationship field in the appHome table that matches the Row ID in appHome (there is only one record in this appHome object), to the response table field “AppID” not work? The relationship is empty.

What have I misunderstood?

Many thanks
appHome Relationship:

responses table:

Are there any columns in your Responses table with Row Owners applied?
Do you see anything different in the Data Editor when you view as different users?

Hi Darren
No, there are no row owners applied at all. Responses table, all fields remain unchanged regardless of which user is viewing the table.

What does the ITE column look like?

Hey Mr Petitto
I am a big fan - thank you for your willingness to share and post useful vids!
Here is the ITE column in user table:

Are you sure you didn’t type any extra spaces before or after the RowID in your IF column?

It might be better to just use a Single Value column to bring the RowID into the user table.

1 Like

I agree with Jeff. Regardless of whether it is the source of the problem or not, hard coding the Row ID in that manner is just asking for trouble. Much better to use a single value column.

1 Like

That’s what I was looking for—there’s no need to use a ITE column here. Use a single value column instead.


Thank you - I will try that - and let you know if resolved my issue.
Appreciate feedback from all!

1 Like

Ok - I changed the value for AppId to a single value column in users table and referenced that in the response submit form.
The relationship includes the new record I just added! Thank you.

What can i do about the existing records - I need them to be recognised in the relationship too. I copied and pasted values from both sides of the relationship into a text editor to compare and I cannot spot a difference? Why are the older records still not being recognised?

Second question @Darren_Murphy why would “hard coding” the value using a ITE be prone to issues over a single value column - just trying to understand principal better so as to improve my Glide “brain”.

Once again - thank you all.

Ok I found the issue with why it was not recognised. The very first character is a capital “i” but I had copied it (using a text sniper tool) from the original Row ID with a lower case “L”.

Why are we prevented in Glide from copy and pasting a Row ID column value?

Thanks again for suggestions - highly valued.

1 Like

That would do it. :stuck_out_tongue:

It’s probably not a matter of allowing it to be copied. It’s probably more that fact that RowID’s aren’t meant to be changed, so it’s a protected uneditable column. It’s not usually a typical situation to copy the RowID and manually paste it somewhere.

1 Like

understood - thanks!

1 Like

We’re not :wink:

You can copy/paste, you just can’t edit. But just because you can, doesn’t mean it’s a good idea.


I stand corrected. :wink:

hehe, one situation where you really do want to be able to copy a RowID is when you are debugging something and need to search for it in another table. I was doing that recently and tried this on a hunch, and was pleasantly surprised to find that it works :slight_smile:


Great tip - thanks for shining light on that one!