Re-publishing problem

I re-published my app over 2 hours ago and all I see is “421 misdirected requests, Cloudflare”.
I have a Custom Domaine and now it’s gone from the Share tab. “Verify your Custom domain” says everything is ok. Previously, republishing took only a few minutes. Any comments?

Is it normal for republishing to take the same amount of time as the first DNS propagation? More than 10 hours have passed and there is no result!

Maybe @Darren_Murphy can shine some light here.

Thanks for your answer, ThinhDinh! More than 17 hours have passed and still no result! I also noticed that my URL has changed. At first, I didn’t pay attention to this because we use custom domain, but maybe that’s the problem?

Can you explain what do you mean exactly by “republish”?

Below is an excerpt from the Glide Docs. Previously, I did this once and it worked after 10 - 15 minutes

“You can also unpublish your project if you need to. There are two places you can do this from: the Privacy menu in Settings, or the Publishing tab under the Share button. When you unpublish a project, all users will lose access to it. However, if you re-publish it, they will be able to use it again as before.”

Then it’ likely the fact that the URL changed that’s contributed to the problem. Can you check all configurations again?

I did not change any DNS records and it was checked and all was green from the time of republishing

6 hours ago republished one more time and reentered DNS records - nothing changed!

I would suggest submitting a ticket.

Thank you, TinhDinh! I already did it. But unfortunately, the support team is only available during business hours, so they will only see my ticket tomorrow, and the application is still not working (