Possible bug? - Nested/consecutive ITE

Hi all,
Although I wrote in the topic that this is a possible bug, I’m quite sure the bug is on my side, not Glide’s :stuck_out_tongue:
In other words, I’m doing something wrong.

Here’s the story:
Building a custom form inside a Glide table, as per the wonderful advise from @Darren_Murphy . This form is quite elaborate so the supporting table has a few dozen columns, many of these ITE. Some of these ITE are used to manage visibility of components. Some of these visibility controllers are based on several “scenarios” of inputs to the form, so I’m using ITE inside ITE to handle this (is this where I go wrong?).
One such example is shown in the screenshots above.
Each of the first two columns handle a given scenario.
The third one is trying to combine the first two. As you can see, this third column should be “true” only if one of the first two is “true”. You can also see that’s not the case. Both of the first two are “false”, yet the third is showing as “true”.
What I have done wrong?
I’ve tried removing this “Final” column and recreating it. Indeed, it worked as expected but returned to its naughty self after a few runs. By “runs” I am referring to submissions of this custom form. This is what led me to think it might be a bug. After each such run all values are cleared (custom action).

WTF!! :upside_down_face:

I had to see it on my laptop but I couldn’t reproduce your error manually.
How many “runs” do you have to wait to see this behavior?

  1. image
  2. image
  3. image

and my final logic looks like:


Do any columns in this table have row owners applied, or do any columns reference other tables that have row owners?


I haven’t counted but I believe it’s about 5-6