Persistent Duplicate Error in MySQL Despite Deleting and Re-adding Record

Hello Gliders,

I have been facing this duplicate error for over a week. I tried to tackle it in multiple ways, but no effort was fruitful. Then, I deleted the record with the ID “2147483647” and tried adding a new record. It still gave me the same error, even though there was no record in my MySQL database with this ID. I even tried to add a record without any ID, as shown in the attached screenshot. I didn’t set anything in the ID field in the “Additional Column,” yet it still gave me the same error

This thread has been escalated. Support will follow up via the Messenger in the Builder or through email.

Just a comment that might provide a clue:

2147483647 is equal to 2^31-1, which is the maximum number that can be represented with 32 bits. So my guess is that you’ve hit a limit somewhere…

1 Like

No, I haven’t hit the limit. I literally have 36 records in the database, and secondly, it is giving me an error even when I try to insert an empty ID.

From what I understand, Darren might mean a limit in how you setup that column in SQL, not the limit of records number.

1 Like

Yes. It could be anything, but that number is too significant to be coincidental.

@Namra - have you examined the action run log to see what is actually being sent?

1 Like

log show nothing

Click on the green tick next to the run date in the history.


So the Set Column Values action is setting the value 2 into the column WL2vD - is that what you are expecting?

(Note: WL2vD is the native column name - if you check “Show API” on the table, you can see which column that maps to).

There is no column named WL2vD in my table.
I don’t understand your note. I can’t find option ‘ShowAPI’. My table is MySQL table

My table is MySQL table and it shows only two option

  1. Unlink
  2. Reload

When you create a column in the Glide Data Editor, Glide assigns a “native” column name which is different from the name that you assign. The native name is static and will not change even if you rename the column. The native column name is shown in the action log. If you check the API usage on the table, you will see which actual column that maps to.

Anyway, the point is that the log shows that the action is writing the value 2 into the selected column. So again, is that what you are expecting?

Can you show me the configuration of that Set Column Values action?

Here is the configuration of the set column values , which indeed sets the value to 2 in the user table rather than the P table. This occurs after the form submission, as seen in the previous screenshot where I did not add anything in the “ID field” of the additional columns in the form container for the P table.

Previously, I tried different approaches to manually add the “ID field,” but each attempt resulted in the same error. I also attempted to add a unique identifier, but the same error occurred. In one of my previous posts, you mentioned that using a Form Container (or any type of add form) will add a new row when it is submitted.

Reference to what you said :Need Help Syncing IDs Between MySQL and Glide Tables - #12 by Darren_Murphy

Therefore, my query is not about what happens after the form submission. I am trying to understand why my form is not submitting

Presumably that’s because of the error shown in your very first screen shot.
I’d expect that error is coming from MySQL, and it looks like a duplicate key violation.
As I mentioned in my earlier reply, the number shown in the error message is a “special” number in the sense that it’s the highest number that can be represented with 32 bits. I’m sure that’s a clue, but I’m not sure where to go with that.
Do your MySQL logs provide any clues?

Also, this thread was escalated to Glide Support - have you heard anything from them?
If not, you might want to reach out via the chat in the Glide Builder.

No, I didn’t hear anything from support team. I thought you were a member of the Glide support team

No, I didn’t hear anything from support team. I thought you were a member of the Glide support team

I just realized I do have a record with this ID in my table but it was not reflected in my glide data sources screen

We are not, we are just fellow users.


Alright, but thank you both, @Darren_Murphy and @ThinhDinh , for helping me solve my issue