OpenAI image generation fails

Team ID:
PH3L89RVIsCkbTPRJRBb

App ID:
- In the Glide builder URL, e.g.
https://go.glideapps.com/app/your-app-id-here/layout

Description
When I use the OpenAI text to image integration it fails, I get an error
image
the integration is set up correctly as it works as expected in other apps in the same team

How to replicate

  • Create a button
  • add openai integration
  • add details

image
image
click button
get failure message

i have a credit card on file with open AI - the integration works with a different app in the same team

it could be because the integration button is on an edit page?

Have you tried it outside of the edit form?

1 Like

I don’t believe 300x300 is a supported dalle-3 size. When using DALL·E 3, images can have a size of 1024x1024, 1024x1792 or 1792x1024 pixels.

https://platform.openai.com/docs/guides/images/usage

2 Likes

This seems to be very inconsistent and oddly (but thanks) both of these points help I think

The AI image never generates inside an input form - a shame as an ‘add image’ or ‘add summary’ button is a great use case.

On the item rather than edit page it works occasionally. Removing the resolution input seems to improve this I think - perhaps fails 1 in 3.

A shame - could be a great feature but too buggy to release to my users

I have a form where on submit an image is generated and added to the newly added row. Works for me, but had issues where an query json column was used in the prompt. I had to add the query json into my action and use the result in my prompt.

aah interesting, so on submit works. Will try that

Wouldn’t you want the users to be able to preview the image though? What about pointing the image picker and the generate image action to a column in the user profiles? That way I think you can still use a native add form, not sure about edit forms though.

Interesting. Do you mean saving a ‘draft’ image effectively in the user column? And then moving to the item field on submit?

Yes, that’s correct. I recall someone here doing it a while ago, I haven’t tried it myself (writing to user profiles columns in forms).