OpenAI ask a question about a table doesn't seem to work for an Excel table

I always get the following system error when asking a question about my Excel table: “Answer question about a table: Could not get embeddings | Bad Request”

When I use a native Glide table it simply works.

It’s a problem since I use the Jira to Excel integration to easily download my issues into Glide.

Is this normal and or is there a workaround for this?

Many thanks for your support!


I’ve had more issues than successes with the “Ask a question about a table” OpenAI feature. Maybe it’s just me.

One issue is that even when set up correctly, the feature seems to only read a subset of the table, and I’ve never understood which subset.

Have you tried importing the data from your Excel into a Glide Table to see if the feature is even doing what you want it to do? If it isn’t, it might not be worth to troubleshoot the issue with Excel.

I’m not addressing your issue directly, just sharing thoughts out loud before you go down a rabbit hole.

How many rows are you processing? You may want to reduce the columns, rows or overall content if the API is struggling getting embeddings back - Usually points to too much data trying to be processed.

it’s only 600 rows and I tried to limit the columns allready. I don’t think the amount of data is the issue since I’ve used this for bigger glide tables before.

thanks for the feedback. I have tried to use the functionality with Glide tables and that seemed to work fine for me. However given the set-up for just an internal application where I want to leverage the Jira to Excel integration this is bit of a bummer.

There’s a bug where OpenAI can’t process empty rows and you’ll get this value. Put a fix on our side to skip these. Hopefully lands this week.


let me know and I’ll test again

I think it might have just landed, can you retest?

1 Like