Numeric Precision ignored

Hi guys,
I have a number column with precision 1 that I Sum and then write to another table to a text column using an action, and ignores the units (that is a known issue with Rollup).
The written value is with the full possible precision.
am I missing something here? bug? any workarounds?
image
image
image

1 Like

Regardless of the Precision set on a number column, the underlying unrounded value is always stored. If you intend to used the value for other math, you should use a math column with a Round function to give it a true rounded value. Setting Precision and Units is only for display purposes.

2 Likes

I tried that too,
still get the full number

Its supposed to show the sum of calories consumed a day,
and I got feedback from my users that were really amazed of the accuracy :laughing:

Create a math column in whichever table your calorie counts are stored, something like Round(Calories,0), and then do your rollup on that column.

4 Likes

Round will only work for whole numbers in the math column, I believe. You can’t specify decimal places. If you need to factor in 2 decimal places, for example, you need to multiply by 100, round, then divide by 100.

3 Likes

Whole numbers will work for me in this case.
I will try

Yep, rounding before summing worked.
Thank you!