Logged-in user cannot be an admin user?


Once signed-in, my user has to create its “company”.
Here, he indicates the emails of “admin” users, including its own email.

Given automatic modification of the user’s email by Glide (cf. “privacy”…), the “admin” email does not match with this user’s email.

There are for sure some workarounds, but I wonder if I am doing something wrong?
If not, isn’t it suprising that such a basic link is not anymore do-able naturally?


How are you indicating a user is an admin? Is it by a “type” column?

In [Company] table: the creator of the company indicates a list of emails → then split
In [User] table: relation & lookup between logged-in user and [company] table

Is this to do with apps notcollecting real email addresses by default?

You can still switch this on in a Pro app.

If not, then feel free to ignore me :slight_smile:

Hi @Mishta_P , yes it is.
I have a Basic App, but while I am only prototyping at this stage Pro app is too early.
In addition, given the importance of this field (“user email”) I cannot imagined that Glide team has blocked it; so it’s probably my way of using it that is incorrect

You may need to ask your users to enter their “real” email address as part of the onboarding process, and save this in a separate column in your User table. You can then use that column to build the relation to the Company table.

It is blocked by Glide for basic apps, I’m pretty sure there was a data privacy reason for this.

Once you update to Pro you’ll be able to collect emails as standard. Either that, or as @Darren_Murphy said you will have to explicitly collect the addresses.

1 Like

Thank you @Mishta_P and @Darren_Murphy, duely noted, even if it is a really poor experience to ask twice our users their email address.

In addition, I have dozens of conditions, actions etc linked to User eMail… To keep the current “email user” column linked to all this stuff, I thought about

  • renaming the original email column into “confirmed email”
  • and creating a “glide email” column, to where I would redirect the “user profile” email column. I hoped that this workaround would enable me to keep the initial “user email” column (now “confirmed email”, populated via the request to user to confirm their email).
    Nevertheless, when I tried to enter data in the entry field associated to this “confirmed mail”, my whole profile screen was frozen …

[edit] Found the issue: a filter wrongly set in the screen

Do you have any clues ?
Thanks in advance