Lifetime membership access, how to access App:Sales

Well we use the formula in cell A1 to clone the Sales Log sheet. But this should not really cause an issue…

I have reported the issue. Maybe Glide Support can take a look.

1 Like

Can you paste that formula ?

This one

Morning. I just went into the App and there was an Error. No idea why but the Glide Tab that showed the history of sales had become detached from any data source. It’s never happened before to me before… it gave an error message ‘screen lost’. I reconnected the tab to the Google sheet and instantly the App behaved fine again.

I then tried to copy the App for myself… and it worked fine. I now have 2 versions in my Glide home page:


The fix above might be a coincidence since it doesn’t seem like a dramatic change but certainly its possible to make a copy this morning. Could you have another go please?


I just had a go at copying it - same error.

1 Like

Ah… this is strange. Well no answer yet from Support. Maybe they can fix it! Thanks for trying though…

Just a thought, what happens if you try to copy my copy?!

Same error. Odd…

1 Like

FWIW, I am following this, and I get the error copying, also. I have yet to get a Stripe account, but I am all ears…

1 Like

I will release my template tomorrow, no extra fees, no problems with inventory adjustment, no problems with App crashing down

Does this app have any experimental column? If so, remove them and try again.

I was going to ask that question earlier, but then it occurred to me that if he did, then he wouldn’t have been able to make it copyable in the first place, right?

@Simon_Hill I just noticed that even though I wasn’t able to copy your app, a copy of the Google Spreadsheet was created…

When I opened the sheet, I noticed that the formula is broken - obviously, because the App: Sales sheet doesn’t exist.

Screen Shot 2022-01-29 at 11.18.50 PM

It’s quite possible that this might be tripping Glide up. So, a suggestion - try replacing that with a static header row and see if that makes any difference…

1 Like

You are right, however I’m trying to diagnose what the cause of it may be.

1 Like

Hi guys - I was away for a while. Thanks for the suggestions. The formula discussed above is key to the spreadsheet working, but maybe if it’s blocking the copying then it can be pasted back in later. Perhaps Glide blocks anything that blocks a reference to a the hidden Sales sheet. Anyway let’s give it a go… I will post once the reference is deleted.

My guess is that you could probably add a second sheet with a dummy header row, even if it’s just one column.

I think the problem might be that Glide can’t attach to the spreadsheet because there there are no sheets with a valid header row.

1 Like

Ok the App is now saved with the formula deleted. Can anyone try copying it now please?

Obviously if this works then the user will have to manually paste the formula back into Cell A1 of the tab Google Sheet called ‘SALES RECORDS’.

={‘App: Sales’!A:Z}

I inserted ‘Temp header’ text into A1. Is that Ok Darren as a temp header row?

Okay, I’m able to copy it now.
But then it immediately complains about missing columns in the SALES RECORDS sheet.
Which makes sense, because all those columns are missing.

I think there might be a bit of a chicken and egg situation here. Obviously, the App: Sales sheet doesn’t get copied when the app is copied, and I can understand why that would be the case. I’m not sure when that sheet gets created, but I guess it’s probably when you connect to Stripe. And because the copied app won’t initially be connected to Stripe, there is no App: Sales sheet. And so the formula to copy that sheet obviously won’t work.


Ok thanks for the persistence and diagnosis! I think you make a good point. I agree that the user needs to make at least 1 test payment with Stripe to finalize the app (when you click on the Buy button in the Glide editor it opens up ‘test payment’ links that can be used without using real money). Once done, it should be possible to paste the formula back into cell A1. Hopefully everything then works…!