Issue with Call API Action - No Response Received

I’m experiencing a problem when attempting to connect Glide with ChatWoot via Glide Call API action. The initial step in this process requires me to create a Contact within Chatwoot and receive an ID to initiate a user there. Unfortunately, I’m not receiving any response, even though the connection works flawlessly through the console and other services. The error I encounter is “Call API: No response.” Could you please assist with this issue?


Can you blur out the authorization headers and show us how you’re configuring it?

Does it work if you configure it as a column, opposed to an action?

Here is Chatwood structure to create a contact that i used to build the Action:

What do you mean by configuring it as a column, I don’t see any possibility to POST and GET APIs in Columns.

Apologies for interjecting, but may I know exactly which action you are using below?

Is there really a “Call API” action?
I’m aware that such an action is in the works, but as far as I’m aware it shouldn’t be live yet.
Or are you taking part in the Alpha Testing group?

Seems like you’re missing this header.

API Documentation Chatwoot Chatwoot 2023-08-06 at 7.12.53 AM

@Darren_Murphy I just checked a free team I have. It is indeed available as an action on Pro, but not as a column like @Bio_Sam said. Maybe only Alpha testers have it as a column.


hmmm, so what am I missing?

I’ve checked a Pro Team, a Business Team, and an Enterprise Team - nada, nothing, not a sausage. What am I missing? (all 3 have all Previews enabled)

That’s weird. I have this on a team where I’m sure I didn’t ask for Call API access.

I don’t remember if it was previously available as a Previews option. Maybe it was, and I turned that on and forgot about it, then they dropped it from the Previews list. :sweat_smile: :

Hey guys, how are you? I identified today, and was happily surprised! It is also available to me in a “pro” team!!! I really needed this solution!!! is it already safe to use it?!

Authorization headers are not safe, for now.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.