IOS Push Notifications Doesn't Work

Hi, I am creating an app that will allow you to raise issues to someone you choose. I cannot get the push notifications to work at all how they should. I managed to get them working but only on my laptop but the account on my I phone doesn’t work at all. My iPhone is updated to IOS 17.5, The notifications are allowed, I turned off safari blocking pop ups, I have a boolean column that is wrote to through a PN access granted action that is done after you click confirm and it works fine as in the box is checked when it should be.
This is the action that should send the notification
I cannot get this to work at all and it is a core component in the app I am creating. Any help would be very appreciated and if anyone knows if maybe its an issue on Glide’s side please let me know.

We have seen various reports about this in recent days. The thing is this feature is still in beta, and is not stable at all.

The team is likely already aware of the issue, but if you want a check, you can send a message through the Intercom integration (bottom right icon) in your builder environment.

I found the source of the problem: The push notification doesn’t work with the “Run App in the new player (Beta)” when checked.

We tried all morning and found out that this was the culprit.

Hmm, so it worked when you uncheck it?

Yes, worked fine after that. I’m guessing the new player really is in Beta.

1 Like

Another thing to note, my other app push notifications stopped working from Monday till today morning, when it worked. Those apps were using the old player.

The “Run App in the new Player” Box wasn’t checked anyways so i don’t believe that is the issue

1 Like

In my app, I had to re-open the app after Allowing Push notifications.

Can you try this?

Nah didnt help at all unfortunately mate