Intermittent ability to edit glide column properties

I’m experiencing inconsistent behavior when adding and editing columns to glide tables. Just spun up a new app using glide tables only. You can see the support link below.

In the table called CYCLING LOG I successfully added a few columns, but now when I try to keep adding, the builder behaves oddly: It adds a column, but does not launch the properties window for that new column. So, I click on the arrow next to NEW COLUMN and select EDIT… nothing happens.

I’m unable to edit the properties. I can’t delete the column either. I then tried to edit properties for existing columns and sometimes I can, but sometimes I can not.

I suspected poor connection to glide server, so exited the APP and re-entered. The only difference is that IF I’ve tried to delete the column prior to exiting, now upon re-launching, I find the column is gone (where it had not deleted previously).

My app’s URL: Glide

4 Likes

Same here, I can´t add or edit column :thinking:

Yes, same. Exactly the same.
Just started happening in the past 24 hours or so.
I’ve seen it in multiple apps.
I’m working around it at the moment by doing a full browser refresh.
Annoying.

1 Like

Does it only happen when you add multiple columns in rapid succession?

Depends on your definition of rapid succession…
But thinking about it, yes - I’d say it’s been most noticeable more likely to happen when I’ve been in the process of adding multiple columns.

Well, I wouldn’t call it rapid succession, but it definitely occurred when I was adding columns in succession. This was born of my frustration with a previous app that somehow appears to have gotten corrupted because it just wouldn’t write to Google consistently. So, I started the a new app entirely in glide tables - which means I need to create a number of columns in succession.

Just posted here:

Same thing. It originated with a succession of columns, yes. Usually glide catches up and I can just do a couple refreshes and I’m back to where I was, but this time it’s not working. See the link above with my video.

1 Like

@david @mark @jason

I think I figured out a way to jostle the GDE when this issue occurs.

Yeah—workaround until the bug is squashed:
@Darren_Murphy @belzoni

Actually, try this…

  • Add columns in the GDE until you get an uneditable one
  • Immediately switch to the Layout View → Data
  • Make an edit to the column you just created - change it to a date column or something
  • Switch back to the GDE, and that column is now editable

That seems to work reliably for me

Edit:

Or maybe not… because even though you can edit the column, you’re stuck with a basic column.
But, I can’t replicate the original issue any more. I just added about 20 columns in quick succession and it worked perfectly. Maybe it’s been fixed already?

Ah! I’m not the only one them. I was about to throw my mac through the window!

3 Likes

If you do, please throw it this way. I could use a spare :joy:

This is becoming increasingly frustrating. A 5 minute job turns into 15 minutes with all the backwards and forwards and refreshing and reloading and in and out and swearing and cursing :face_with_symbols_over_mouth::face_with_symbols_over_mouth::face_with_symbols_over_mouth::face_with_symbols_over_mouth::weary::weary::weary:

4 Likes

Same. No response / feedback from Glide Team as yet?

David is aware of it (see earlier in the thread), but no news regarding a fix that I’m aware of.

1 Like

Actually had a quick but heavy Glide session today and not a single instance of this issue … maybe :crossed_fingers:

yeah, it does seem to be a bit intermittent - the worst kind of bug to try and squash.
But when it’s bad, it’s really really bad.

So much so, that I have abandoned several Glide projects. I can’t waste my time this way. I hope to come back to them some time soon. But this, along with several other weird problems I’ve been experiencing since the recent update have made the platform untenable. I’m still in the first 1/3rd of my development cycle and wondering if I should cut my losses and find a different platform.

:frowning_face:

1 Like

Given that this issue is intermittent, I wonder if it is network related?
ie. perhaps there’s something in the new Glide builder that doesn’t cope well with intermittent or poor network connectivity?

…just thinking out aloud

2 Likes

I originally thought the same thing (network connectivity). But the pattern of behavior (insofar as I could tolerate it) pointed to NPNP (the term I just coined for not-purely-network-problem). I experience no such problems anywhere else in the GDE or when running my app through the GDE. To my admittedly-ignorant eyes, it’s specific to this function.

I’m not coming back, quite yet. But I’ll watch here to see how things progress.

1 Like