Inconsistent Query Results: Preview Shows Multiple Rows, Saved Query Shows Only One

I am using a custom query that includes a binary column. I added a WHERE clause to filter out values that are true in this binary column. When I preview the query, it shows multiple rows, but when I save it, it shows only one row. Does anyone know why this is happening?

P.S. I tried filtering for false values as well, but I got the same results (one row when saving, multiple rows when previewing).

Ok so I solved it myself, but I am writing the reason which according to me was causing this issue all the columns in my table have same values except for this one column so when saving a custom query we are asked to ‘Select an ID column for your table’ we should select a column with different values (basically a column whose value which could serve as a unique identifier for your the table created by custom query) and this issue was not simply resolving by saving again with Unique ID so you to have to write custom query again

1 Like