BUG? - Query

I am trying to display query results is Classic Apps and it has been a nightmare.

The GDE shows everything is correct - but Layout shows wrong data (and the app on my phone).

I have deleted all row owners on the ‘subject’ query table to eliminate that as a problem.

It is frustrating to see the correct data in the database and in the data viewer within layout yet have only SOME of the data accurate. Some is correct - some is not. All coming from the same table.

How is query working for others in the community?

1 Like

I was going to post something similar. In Pages, in the data editor the query will display data, but when that query is used as the source for a component, some queries display correctly and some are blank…no data displays on the front end even though the data editor shows that the query returns data. Not sure why that would be the case.

Same here. I am trying to narrow it down. But it seems, sadly, pretty random.

I reproduced it creating a query with a single match and a relation with the same match.

Both showed the correct amount in the Editor.

When displayed the relation showed the correct count - the query showed 0.

I closed the app to do some other stuff and when I just went back to it - they both displayed properly.

I am wondering if this is a weird caching issue.

1 Like

I agree!

Some weird stuff are happening with Query column currently. If I try to filter a simple value, the query replies with wrong values

It seems that filters are not working (or enjoying this weekend :beers:)


1 Like

For me works well

Playing around with it today, it seems very useful, but I’ve concluded it must have a bug. The query seems to deliver the right results for me. The problem I’m seeing is that the data does not display even though the query returns data. This is happening in weird ways. For example, I have built a template using html tags that joins data through a relation to make a template that can be sent in an email. I rebuilt a version of it today using the query fields instead of the convoluted method that I had originally built it on. That part, on the backend, works great. And as you can see here, the query delivers data as expected:

However, when I display this in a preview window that I created, the data that is fed by the query disappears. Only the data from the static field headings shows up.

Meanwhile, if I switch to the original template (which is exactly the same except for relying on different, non-query columns), it displays correctly.

Also worth noting that it did work originally. When I went back to test it later, it no longer worked.

Still does not work.


When I use a template field returned via a lookup in the source (Meeting table) - the result is correct in GDE and incorrect when displayed/rendered.

When I use a regular field (not a template via a lookup) in the source table (Meeting) and a lookup in the current table the result is correct in GDE and ALSO when displayed/rendered.

Here are the results:

The data in the row/column is correct in GDE and in ‘Data’ in the layout editor (correct answer is 2). Display is 0.

As rendered, it is incorrect (s/b 2):

As shown in Data display for the row:

I am using a lookup field (which results in a “template” - Convert.QY) in the source “Meeting Table” and the the same lookup field (same “template”) in the destination “Territory” Table.

When I change the source to a field (From Convert.QY to ‘This Year’ - ‘This Year’ is hand entered and is the same result as the lookup data) I get the correct results rendered.

Result in data:

Result rendered is correct and matches the data in GDE:

Okay - the issue is the template in the Source.

A. The filter in the Source is a template compute column (via a lookup).
Result in GDE correct - Does NOT render correctly
B. The filter is data (exact same as the data via the template)
Result in GDE correct - Renders correctly
C. Turned field data from B. into computed template field.
Result in GDE correct - Does NOT render correctly

In certain instances when using a template field as a filter in the Source - the rendering defaults to 0

1 Like

I have let the team know about this.


Could I get a clear reproduction of this bug with a support link and an explanation please?

Thank you!


On the dashboard of your team, click the “three dots” button when you hover over an app and choose “Get support link”.


Then, please try to explain your problem as clear as possible. I believe you should always have these:

  1. Steps to Reproduce: Describe the exact steps required to reproduce the bug. It typically includes a sequence of actions, inputs, and conditions that lead to the bug’s manifestation. This information helps the team understand the bug’s context and aids in its replication for debugging. If you can, please also attach sample data.

  2. Expected Behavior vs. Actual Behavior: This highlights the discrepancy between the expected behavior of the app and the actual behavior observed due to the bug. It describes what you expect the app to do versus what actually happens when the bug occurs.

  3. Screenshots or Video Recordings: Visual artifacts such as screenshots or video recordings can be used to provide additional clarity and visual evidence of the bug. They can help the team visualize the bug and aid in its reproduction and resolution.


Will do - later tonight. It is my wife’s birthday :slight_smile:

1 Like

Please send my best wishes!

1 Like


1 Like


@Mark - I submitted a ticket based on a test app I built to more simply demonstrate/recreate the issue. It is modeled on the usage within my app. FYI - I am a Pro user but the test app was built under a normal free ‘team’ to make it easier.

Here is the results - all answers should display as 2

1 Like

@MattLB could you send me a support link please?

Done! Thanks for looking at it.

I did and she laughed knowing how much time I have spend in Glide-world!

Have a great rest of the weekend