Im getting an error message when I try to copy an app

Im unable to copy an app. Please help.

What’s the error? Do you have a screenshot?

Screenshot (801).png

Did you sign up for Glide using a Gmail account, and if so, did you use Google’s authentication to sign in? I think it’s trying to save the google sheet to your Google Drive, but if you didn’t sign up with a Gmail account, then there is nowhere to place that google sheet. This limits you to only apps using Glide Tables. Anything that uses a Google Sheet won’t work.


I have the same problem, when my google sheets have large count of rows… i guess Glide can’t handle more than 25k rows when duplicating… if that is your case, try to copy GS, delete data… duplicate the app, and paste back that sheet

Is that the same error though? Yes, big sheets can cause copy issues, but in this case, I’m wondering if the glide account is not attached to a Gmail/Google account. Glide now allows users to create accounts that aren’t Gmail/Google authenticated, so those users are limited to only using Glide Tables.

that is exactly same error i’m getting when duplicating app with large count of rows
( i did not test what is the maximum allowed and not sure if it is count of rows or total data)

1 Like

I did sign up using a gmail account and did the authentication several times as it kept redirecting me.

1 Like

This has happened to me many times and I can confirm that this is the error message received when my sheet is too big or complex.

You could try making a copy of the underlying GSheet, delete as many rows as you can and then “replace” the old sheet with the new one. Next duplicate the app and when that is done you could swap the old GSheet back using “replace” again.

FYI you must leave the structure of your sheet exactly the same. Do Not remove any columns during the swap, only remove rows.

1 Like