I deleted a record and my whole account does not exist anymore

Hello, I would say I am pretty new to Glideapps so I still make a lot of mistakes.
I have created this project (Glide pages) on which I have been working for more than 15 days now and today, while I was modifying some fields in the users table, I have deleted a record which only contained an ID and an email address.
After deleting the record, I tried the app but it did not work, I have tried with other emails of people which are part of my team and it did not work either.
Moreover, I usually login into glideapps using my Google account but now, whenever I click on login with Google, I can see this message saying that my account does not exist. Note that even when I try to log in with another account (of my same team) I always see the same error message.

Can anyone explain what is going on and if there is a way to recover all the work that I have done?

Thank you in advance.

Hi Alessandro,

Glide is experiencing an outage - I am experiencing the same issue as well.

The Glide team is on it and hopefully all will be back soon!

1 Like

its back! You should be good to go now


1 Like

Issue is now solved ! :slight_smile:

Please create a new topic if you experience troubles using Glide.

1 Like