Google Drive not connecting

I am trying to create an app as part of a training session (my first app!). When I click to create an app by connecting to Google Sheets a Google authentication window is spawned. Once I authenticate and that window goes away Glide seems to be hanging - the little progress animation just continues on and on. I am unable to escape out of it and need to close the tab to get the normal Glide page.

I’ve tried shutting down and restarting (always the first step) but still have the problem. The drive I’m connecting to is under the same account that I use to log into Glide, so there shouldn’t be any permissions issues at play.

Help? :slight_smile:

Did you ever get an answer to this? I’m having the same issue.

Do you have any ad blockers running maybe?

I ended up using Safari and it worked like a charm.

hope this helps!

In addition to what Jason has said, sometimes Google authentication stops working weirdly for me in many sites when I use uBlock Origin and Privacy Badger. Check for those types of extensions and temporarily disable them to see if the problem can be solved.